Sound does not play if too short

When I play a sound, and it’s short( shorter than 1 sec ), and has attenuation settings, it does not play.
If I make a sound cue, and put a 0.2 sec delay in it, it plays normally, although it does not work if I lower the delay to 0.1 sec.
I can provide a sample audio if you want.

Hello honya15,

Would you be willing to test this in the 4.13 release of the engine?

Could you provide me with the sound asset in question so I can test in both engine version on my end as well?

I would also like to know if you have modified any of the Sound Wave compression settings, or made any changes to the Sound Cue properties.

Let me know if you have further questions.

Cheers,

Andrew Hurley

Thank you for your answer, I don’t have currently 4.13 installed, so can’t try it out at the moment.

The sound file is here: https://dl.dropboxusercontent.com/u/2055073/attack_1.wav
Just import it, attach a sound attenuation to it( the default is enough ), and play it with SpawnSoundAtLocation, and voila, it doesn’t play. If you remove the atten settings, it works.

Ok, here is the thing: If I do it by blueprint, it works fine. However, I was using cpp code, a line like this:

UGameplayStatics::SpawnSoundAttached( Sound, GetCapsuleComponent(), NAME_None, FVector(), EAttachLocation::KeepRelativeOffset, true, 1.0f, 1.0f, 0.0f, nullptr, nullptr );

I found that the default parameter for position is FVector(ForceInit), not simply FVector(). Corrected that, and it all worked well. Seems like FVector() does not initialize the variables inside, this was an error on my side.

Still strange though that it works with longer sounds…

Anyways, thank you for taking the time to help me!