Sound Cues Randomly not working

We’re having a consistent issue with soundcues not working.
It appears to be completely random.

Sometimes the full soundcue shows a flow through the nodes, but no sound is playing.
Sometimes you can play individual nodes but output doesnt work.
Sometimes playing the full cue works, and individual nodes doesnt play.
Sometimes you can copy all the nodes from a non-working cue, to a new one, and everything works.
And then when you restart the editor it’s random if that cue is then working.

It seems to be completely broken, and it makes it impossible for us to work on the sound for the game.

What could be the issue here, and how do we solve it?

Hey Fred-3DR,

Could you provide me with a screenshot of you Sound Cue set ups for a few of the sounds you are using?

There is a known and reported issue with certain nodes like the ‘Concatenator’ causing sound cues not to function. You wouldn’t happen to be using this node in the sounds you are experiencing issues with, would you?

Edit: As MinusKelvin stated, I meant the ‘Attenuation’ node.

Thank you,

I believe may be referring to sound attenuation nodes since I recently fixed an issue that is getting hot-fixed in 4.11.2 which might be the likely cause of this.

Hi Andrew!

We’re only using Attenuation and Modulator nodes, so the cues are very simple.
But they seem to break randomly.

MinusKelvin, is there a Hotfix we can apply ourselves?
I found this thread:

Yes, the attenuation nodes are the issue. The hotfix is not out yet, but the fix I described in that thread should work.

If your MP4 file includes audio codec that is not accepted by your device or player you can use a professional MP4 video converter - iDealshare VideoGo to convert your MP4 file to your device or player supported one with supported audio codec. How to Solve 'MP4 Plays but No Sound' Issue?

I know this is an old post but came across this looking for a resolution. Another thing to check is that you don’t have an empty pins on your input nodes such as the “Random” node. I spent a bunch of time thinking it was concurrency settings, max hardware sounds, etc only to finally see an empty pin on input and thought it can’t be that - and it was (5.1.1). Didn’t notice it before as empty pins are usually ignored but not here. Be sure to right click and “delete” any unused input pins on nodes such as “Random”. So for me it truly was randomly not playing a sound.