Sound bug (like 2x played)


Im using sounds from this pack:

Very simple BP:

30s video:

Bug explanation: As you can hear, when i somehow overlap “sound spawn location” before sound is completed, then it spawn another sound like impact - this works only when i move forward, if i move to another sides, second sound is not spawned. Only cues are bugged, solo sound do not doing this, and impact cues also are not bugged.
Can i do something with that or i need to wait for repair from your side?

Can you reproduce this issue in one of the blank template projects like the First Person Shooter template?

I would need a way to reproduce this on my end to be able to determine if this is an engine bug. I tried to do this on my end, I did not get the same results.

Let me know if you have further questions or need additional assistance.


Yes, problem still occurs.
Now i created new project based on third person template, added to base character Z → play sound at location, again i used rifle_fire_cue and same problem still occurs… (i copied only sci-fi weapons pack from my project in 4.13 because that pack is still not compatible with 4.13 engine but i really never changed anything on that pack, pack was added to my main project maybe on 4.11 engine version)…

So if you are using content from the Marketplace that is not compatible with an engine version, that would be something you need to bring to the sellers attention. They are responsible for providing support to their users and keeping their content up to date.

As I mentioned before, if you can reproduce this using the Starter Content sounds and provide me with steps so I can get the error to occur on my end, then we can investigate further.


Starter content sounds are ok i think (not tested them all).

So i decided to dig deeper and installed 4.12 engine. I installed supported scifi weapon pack to it and tested it on blank project and on third person template. It seems its bugged only in third person template.

That pack is also created by epic games i think so i decided to find help there (in product description is contact on epic). But anyway, its bugged on 4.12 engine version which pack supporting. (when im moving forward then im getting that strange double-sound)

very short 12s video:

Could you provide me with steps and/or this test project so I can reproduce it on my end?

Also, if the starter content sounds are working as expected, then we can assume the issue is associated with your sounds from that pack themselves.




  1. Create new project based on third person template
  2. Add sci-fi weapons pack to project
  3. inside third person character create input (hotkey Z or action Fire, anything), drag wire to “play sound at location”, select some firing cue sound (for example “rifle fire cue”)
  4. drag “get actor location” to “play sound at location” location
  5. press play and hold forward movement and shoot while moving, then try to move to other sides (right left back)

(in first post in this topic you can see my very simple BP - 3 nodes)

Well, that pack is from unreal engine marketplace, created by epic, so i really dont know where can be issue, but i dont think its mine issue because im adding fresh pack to fresh project… This is the most strange bug what i ever seen and i really dont have any idea how to fix it. Its easy to reproduce… please try it :slight_smile:

Unfortunately, I cannot reproduce this issue using the content from the marketplace as, although the support for the pack you mentioned does say answerhub, you need to contact the marketplace support team for this particular pack.

The pack says not supported yet for 4.13 which means what you are experiencing could be expected. The pack was authored by Ying Pei Games, so emailing the marketplace and letting them know the pack needs updating is the best solution I can provide. I was unable to reproduce this issue using the same setup and any of the default starter content sounds.

Thank you,


  1. Sound is good but with engine input - bad…
  2. I described reproduce setup with supported 4.12 engine.

Ill write to them (ying pei)… but i think its engine bug.

Oh, now i see it. I didnt know you have more teams like for bugs and for marketplace :slight_smile: so i posted it to marketplace answerhub.
Sorry for my spam, but thank you for your time!