Sound bug Android

Hello, recently I switched from 4.8 to 4.10 and I have this problem.
I just created a blueprint out of a Sound Wave and did this:

66879-imag.png

Put the blueprint into the level, the sound seems to play fine in the play mode, but when I extract it into apk, in smartphones, it loops for 3 times, and then plays normally, like it’s stuck for a while.
My Sound Wave configuration:

What is the problem?

Hello Jim,

This is a known and reported issue UE-21709, and we plan on having it fixed in an upcoming full engine release. Until that time, you can use a known workaround by adding a delay node in before calling your Audio component to play.

Thank you for taking the time to report this issue, and let me know if you have further questions.

Cheers,

Andrew Hurley

Thank you very much for the workaround

how long should the delay be?
Tried with 0.2 s but didn’t work.

Try using a longer delay like 2 or 3 seconds to see if that works.

tried with 2 and still doesn’t work… and besides that I need the sound to play immediately, can you recommend any other way of playing and stopping the sound?
the reason I use Play Audio is because I can stop the audio afterwards.

I will try changing the Start Time, instead of putting a delay for the moment

ok worked for me setting the Start Time to 0.001

ok worked for me setting the Start Time to 0.001


Yeah, that workaround works better than the delay. Glad you got it to work.

thanks man.
I had the same problem.
this really helped.