Sound Attenuation Not working with Media player

Alright guys I will try to keep this short. I have done all the digging I can, have watched all the live training on this for when unreal changed it in 4.18 how media files are handled and I can’t seem to get this working. OK so let me break down what i’ve down

I’ve imported my media texture, it is being referenced from a media file on my computer. I have the material made for it and the Media player. It plays fine on my model ( a tv)
However, there is no sound attenuation no matter what i do. I made the Tv a blueprint and inside of that i have a media sound linking back to my media file so it plays the sound and it does. How ever its just full on blasting the video audio with no attenuation. I have an attenuation file I have made for sound ques in my map that works beautifully. How ever when I apply it to the media sound in my blueprint it does nothing, I also tried override settings for attenuation and no luck. I will post pictures below of my set up.

My files

Blueprint with my mesh with media texture applied and Media sound source

Media sound settings

my blueprint set up

Attenuation Settings are cached upon starting a Sound Source, so you would need to set it before activating the Media Sound Component. However, I would expect the details panel settings to be used at least. Which version of Unreal are you using?

For whatever it’s worth, as much as I hate necroposting, I am using 4.25.4, have a BP with static mesh, media player, media texture, and media sound component pretty much functionally identical to the OP, and have similarly dug through and attempted everything I can find to get attenuation to work without success. I even attempted creating an attenuation setting file solely to set it before hooking it to the media player:

It is pretty much only comprised of these same settings since override wasn’t working:

There is zero difference between this set node existing and not, or the override being checked or not. I’m not sure of any way to set the attenuation any earlier than this, so perhaps I missed something somewhere. Likewise, spatialization does nothing, as the sound simply plays everywhere, from apparently the center of the player character’s head, as far as I can tell.

I swear, at one point I got attenuation/spatialization to work, but that was only before there was any other code involved, and I have not been able to get it to work again since I added code initially, in this, or in any other project.

I would honestly think that getting the video to work correctly would be significantly harder in my particular scenario, as it runs through quite a few functions before the screenshot above, which is the last thing before final output, but that works flawlessly. I don’t suppose anyone who’s actually gotten this to work in a functionally similar setup would be kind enough to maybe post what the heck they did that actually works?

I have spent days on this issue at this point, and feel like I’m getting nowhere for something that most answers seem to indicate is(or should be) trivial, but never really explain/demonstrate this supposed triviality working. They either suggest one specific thing (that so far has not worked for me), or the"answer" is whoever posted the question saying they gave up or figured it out with no details provided about the solution or alternative in most cases. Or links to the not-there-any-more wiki.

P.S. Actual official documentation of any kind for the media sound component beyond “hook it to the media player” (which has apparently been a thing since 4.18), should probably exist somewhere. Just a thought. It would save a lot of these (basically unanswered) questions about the thing.

Update Edit: I will leave the above because I think the frustration part of figuring this out piecemeal over days of searching/watching/flailing is very valid.
And I might as well post my positive results to not propagate the frustration further.

Tl;dr - Setting the attenuation before hooking to the media player was in fact the solution for my scenario. In my nearly blind rage, I forgot that my sound classes launch from my main menu, and don’t load when I start in the level I am placing the media player(s). That’s very much on me for not realizing I was using the wrong sound classes, I suppose, though why using a different sound class negates the attenuation setting, I have no idea.

To summarize: Using the set attenuation node before hooking to the media player as above, and when using my own sound classes (which bypass the engine defaults, and as far as I can tell do nothing else), attenuation and spatialization work fine. Default Music and Master sound classes, for me, resulted in max volume blaring, or no sound, respectively.

P.P.S. - I still submit that anything like proper documentation would have made this significantly faster/easier, as I got the video stuff working in under 10 minutes following the UE documentation for it. This was my, I think, 16th or 17th similar-just-reworded-Google search for an actual answer to this and similar questions about getting media component sound to work at all, and to do the rest of the things it’s clearly capable of doing. Super frustrating to have to hunt for what should be very easy to find.

1 Like

I don’t have a solution to your problem, but could you tell me how you got the Volume control to work?

The solution is simple.You cannot change settings of audio component once it is activated,So first set all the settings and activate it.There is an option called auto activate in audio component.Disable it and activate it manually from blueprint