Download

Sound Attenuation Doesn't Work on Object Interaction

Currently working on sound effects for a house and I’m trying to add attenuation to the sound effects. Followed a pretty good tutorial on what all the options within the attenuation menu do so besides adjusting the distance, I think I have it set the way I want. Problem I’m having is the attenuation only works when I place a sound cue in the level. If I attach it to a interact-able door, it completely ignores the attenuation setup. Don’t know what I’m missing to make it not work.

Here is the sound cue:
soundcue.png

Here is the attenuation:
attenuation.png

Anyone have any ideas? Can’t find any info on how to have it work with an interactable object. If I place the sound cue in the level and set it to looping it works but I need it to work when someone interacts with the door.

Not sure what your BP setup is with the door, but it should be using the attenuation setting. Have you tried setting it not through a sound cue node but directly on the sound cue itself? In your case, you’re not doing anything special with sound cue attenuation node so if there’s a bug there (which there may be), should be able to work around by just setting it on the output node directly.

atten.PNG

How do you have the sound hooked up in the blueprint? You can add the sound to the BP as an audio component, or you can use SpawnSoundAttached and attach it to the door. There is nothing wrong with using the attenuation node, though it is easier to use the attenuation on the output on a simple soundcue like this. Can you show your BP setup?