Sometimes only able to select faces

So, not sure if this is a bug or a feature but sometimes when I am trying to select an object that I have placed in world, like say stair brush, I am only able to select faces of it (from which you can add a material) instead of getting to parametric options (like number of stairs, radius, etc) and I have to go into scene outliner to select stairs that way. Am I doing something wrong or is this a bug?

Hey Knobby,

In your Modes panel, make sure you have Place selected and not Geometry Editing. You should only be able to select a face on a brush while in Geometry Editing mode.

Hope that helps!

I’m currently running into this problem with a “curved stair” brush, even after making sure I have “Place” selected on Modes panel I am not able to select brush by clicking on it in viewport, I have to use outliner to select it and be able to see brush settings on detail panel.

Oddly enough this doesn’t happen with new brushes I place. Is this a bug or am I missing something? (I’m pretty new to UE4 so there’s a good chance it’s latter)

Hey hnsr,

You mention this doesn’t happen with new brushes. Which brushes does it happen with? Do you mean projects from a converted project? Which version of engine are you using? Thanks!

Thanks for response! It was happening with brushes I added some time earlier in current project/level, however I have since discovered that layer containing brushes was hidden (even though brushes were still visible in viewport, but maybe it’s meant to work like that); after unhiding layer I can select everything normally again. (If it still matters, I’m running 4.4.1)

I am having same problem with 4.10.2. Most of time, if I use geometry editing so much time, I can’t select objects that are edited with geometry editor. I can only select them through world outliner. Yes, I switched to placing mode but it still selects faces only. Restarting engine doesn’t fix problem. I had to turn buggy brushes into static meshes.

You can select faces of BSPs while in Place mode, but you shouldn’t be able to edit BSP while in that mode. If you’re only getting face on first click, try clicking that same face again once or twice, and you should get widget for whole actor. Being able to select face allows for quick texture setting. I’m not sure when this changed, but it’s been this way for a while now and definitely true in 4.10.2.

Clicking same face doesn’t work for me (4.20.0). Clicking off and back doesn’t work, still selects face. What’s going on?

It appears that brush actor is indeed selected, and if I scroll down in “Details” I can adjust its properties, but this is annoying. My workaround for now is to just hide “Surface Properties” group in Details so I can see “Brush settings” one.

I also notice that for instance when clicking on stair brush, if I click on an edge (between two faces) it gives me what I want, just selects brush. But obviously this is not an ideal way to select thing.

I’m watching a tutorial for an older version of Unreal, and in that version guy showed you can click out and back on to be in right mode. Did that change at some point?