Somethings wrong with epic games launcher and unreal engine 5

Okay so 2 days back i was working on my ue5 project as usual and I was tired, so i saved it, closed the editor shut my pc down and went for a walk. After coming back I turned on my pc and opened up the editor, or sadly tried to open the editor. But it didnt open.
I clicked on it multiple times, but it only showed the blue loading ring icon beside the cursor. And it never opened. I checked the task manager and it was actually running ue5 in there. But I couldnt see anything open up as a window. So i tried launching it from epic games launcher and to my surprise the launcher didnt open either. Same blue loading ring comes besides the cursor and nothing happens but i can see it in the task manager

Things that worked :

Things that didnt work:
• tried ending all the processes and running it again as administrator.

• clearing the app data files for the launcher as well as the editor.

• uninstalling the launcher and freshly downloading it again.

• uninstalling the editor and installing it again.

• updating all my drivers.

• trying every single thing mentioned in the forums and blogs and youtube videos about simillar issue

• Factory reset my pc and clear all my data from the C drive and lose all my apps and downloading everything fresh

• Factory resetting again and downloading windows 10 this time as previously it was windows 11.

Things I observed:

• Well turns out, its not that it is not opening. After I restart my PC and i double click on the launcher or unreal editor, it opens after 20 mins or more.

• After waiting for 20 mins for it to open, I close all the instances and processes from the task manager and reopen it. This time it opens up instantly like it did before(both the launcher and the editor)

• I again turn off my pc and turn it on. Now I try to open the launcher or the editor again. Not surprising enough it again takes more than 20 mins to open up and after it opens up. I can close it and reopen it and it works fine.

My conclusion is when i restart my pc something messes up with the launcher and the editor and basically any application i downloaded via epic games launcher. All my other apps seemed to work fine.

I have no clue what to do it doesn not throw any errors or anything its just frustrating that i had to lose all my softwares and start from a fresh pc and yet not getting the problem fixed.

And no my system is not slow.

Im using 16 gb ram 3600mhz , i9 10th gen cpu clocked at 4.7 Ghz, Samsung evo pro 1 tb SSD.

This issue just suddenly has occured, and it sort of appears ghostly because I literally factory reset my pc yet it didnt do anything. If anyone can help me fix this it would be highly appreciated, thanks for taking your time to read through this.

I got the same Problem since the update to UE5.02. Epic Game Launcher is very slow, unreal Engine 5 wont start up somehow… atfer one houre of restarting the launcher and trying to start UE5 it somehow opens, but cant figure out a logic pattern behind it.