Someone help me please? I have a big problem

Hi, I change the scalability to “Epic”, and my editor crashes. After that I try to open the project again and it doesn’t open. I lost my 2 big projects, that I had a big job to do.

Does anyone have any ideas on what to do?

Thanks in advance =)

It is possible to change scalability parameters manually outside the editor.

1 Like

Hi, thanks for the reply, I did that but it didn’t work. Now I have another problem, I create the project I can use it, but if I close the editor I can’t open it anymore. I’ll see if uninstalling and clearing caches and reinstalling works.

Thanks for the reply =)

You could also create an empty project (with scalability set to low) and migrate your projects levels to the new empty project. This should practically recreate the project minus assets not used in any of the levels.
Also, don’t forget to migrate project settings afterward(unless they contain some old scalability settings).

1 Like

Looks interesting I’ll try, but my other problem is creating a project in C++ using the Rider for Unreal engine and as soon as I close the editor and open it again it just doesn’t open. I use MacOs Catalina, I’m also using Unreal Engine 5.0.2, my IDE is Rider.

Lol, you cant migrate without opening the project in the first place.
I should stop giving advices to people.

Don’t stop giving advice you are a guy who is helping me a lot

Hi, I noticed that you gave up I don’t know, but i finally fix the problem.

I just uninstalled and cleared the unreal engine caches, then installed again, it worked.

Thank you for your time and for your dedication to the answers =)

As the OP said don’t beat yourself up. You tried to help which is more than a lot of other devs do. So many users now only post when they have a problem and never help out more than that. Anyway, anyone on here whose ever suffered project corruption or crashes on start will tell you, there are always other options.

Sometimes its necessary to start out with a blank project, copy in assets using OS file mangler, and then migrate assets back out to a new project or the original one stripped down. Also it REALLY helps to have more than one rig to test on (preferably a second rig using a different OS / version of UE if possible). :wink:

It’s really good to hear this, I’m not going to beat myself up, I’m new to the forum and I realize that the community is active, my problem scared me a lot, as it’s the first time this has happened.

But dude thanks for the golden tips you gave me is for taking the time to write this.

Really thank you very much =)