Some particles not colliding with collision enabled?

I have a very large snow particle GPU emitter doing all of the snow particles for the entire level, and it looks/works great. However, within the buildings in the map, about 50% of the particles go through the walls/ceiling, while the other half collide properly. Could this be due to the large number of particles (~20,000 snowflakes a second), or am I missing something from the collision settings that is allowing a certain percentage of the particles through? The meshes for the buildings are simple enough, and have complex collision enabled. The only alternative I see to doing this, is having many smaller particles emitters scattered around the outside areas of the map, but this still poses a big problem seeing as there are open areas on the roof and gardens of the buildings, which would need to have the particles falling on them, but not going through the geometry. Thanks!

I am also having this issue, anyone have an answer?