Some Niagara particles colliding in the air

Hi All,

I am delving into Niagara particles. I have never used cascade, so this is new to me in this corner of Unreal.

I have a particle system emitting static mesh particles with a fountain and a burst emitter in it.
I have this emitter attached to a simple AI enemy that has no collision set on it. That is moving around the level.
I have my particles set to where Particles.HasCollided True set my drag value and set my Acceleration Force Value.
The idea is when the particles collide with the object , they slowly burrow through the mesh, and then after a short time the will die off.

I would say 90% of the particles do what they are supposed to do, but I have a fair amount of stragglers. The stragglers that I am worried about are the ones that are floating in the air right after they are emitted.

They eventually will disappear but it doesn’t look great. Not sure if there is a way to kill those right off the bat or whatever else. I am stumped on this one and there isn’t a whole lot of Niagara info out there, especially dealing with collision.

This guy’s just done a whole series on Niagra, I do recall stuff about collision:

Between this guy TharleVFX and CG How is where I was getting most of the Niagara info.

I tried what TharleVFX did in the video which was creating a collision event and sending the event to another emitter to receive the event and spawn particles. I duplicated my emitter and set to spawn one particle when the first emitters particle collided, unfortunately I was getting the exact same results.

However, It got me thinking and playing with my settings. I did find a work around and from testing it it seems to work.

So on my Drag and Acceleration Force I already had my Particles.HasCollided boolean set up.
I just added a super fast curve to ramp up to the values that I had set for them.
The time is from .1-.2 ramping to my values.


Is it a solution? Sure.
It doesn’t explain why it was happening in the first place, but it works. As far as I am concerned this is resolved.

Thanks for link!