Download

Solved: Why a mod runs in PIE/single player/non-dedicated... but not in dedicated server

In the history of miserable, shitful reasons for things not working… this has to go into the top 100.

The dedicated server command line has to include the map name NOT the mod name in the launch line. Map name… as in your_map_name.umap.

e.g.

WRONG: ShooterGameServer.exe /Game/Mods/[mod_id]/[mod name]?listen?ModId=[mod_id]?etc. etc.
RIGHT: ShooterGameServer.exe /Game/Mods/[mod_id]/[map name]?listen?ModId=[mod_id]?etc. etc.

In my case, my cooked map was Storm.umap… so when I tried to use ShooterGameServer.exe /Game/Mods/481947269/Ultra-Realism?listen?ModId=481947269 when I should have used Storm

Yes, it is the name of the level that points to your gamemode and gamedata files, this is how the server begins it process of reading the mod files in place of the core game files.

The beauty of hindsight, huh?

Well hopefully this post helps someone else in the future… I don’t recall it being documented anywhere else.

Lol… what I say 99% of the time working with UE4… lol… it all makes perfect sense!!! (after)

This is actually very well documented. In the how to make a mod sticky it’s mentioned last time I checked. I have a feeling you just misunderstood what was meant by it or just simply misread it since there really is a TON of info about the Dev Kit already to keep up with. Really happy to hear though that no more issues are presenting themselves :smiley:

  • Sinari