[Solved]Visual Studio 2013 Pro Can't compile .dll

so it seems that i cant compile the first starter project shooter in vs 2013 pro

i keep getting this error no matter where i create the project this keeps happening

The project could not be compiled.
Would you like to open it in Visual

Running C:/Program Files/Epic
MyProject Development Win64
-rocket -editorrecompile -progress -noubtmakefiles @progress push 5% Parsing headers for MyProjectEditor
Running UnrealHeaderTool
-LogCmds=“loginit warning, logexit warning, logdatabase error” -rocket
-installed Reflection code generated for MyProjectEditor in 8,0435948
seconds @progress pop [1/10] Resource
PCLaunch.rc [2/10] Resource
ModuleVersionResource.rc.inl DBSBUILD:
could not get full path for tool -q
ERROR: UBT ERROR: Failed to produce
Total build time: 21,10 seconds

does anyone one know how to fix this ?

also could it be an extension causing this problem or an add in ide such as Xamarin ?


List of all my extentions

ill be disableing these one by one

AnkhSVN - Subversion (Cant uninstall this just yet)

Behavoirs SDK(XAML)

Get Xamarin

Microsft Advertising pubCenter

Microsft Advertising SDK for Windows 8.1

Micnosft Visual Studios ASP.NET MVC 5

Micosft Web Developer Tools

NuGet Package Manager

Visual F# 3.1

Visual Studios Extentions For Windows Library

Visual Studios Installer Projects

Visual Studios Spell Checker

Windows Phone 8.1 SDK Integration

Workflow Manager Activities

Xamarin For Visual Studios


Thanks to

we finally got to the bottom of the problem it seems that SN-DBS

is breaking UE4

fixed by uninstalling it



It is possible that your extensions or Xamarin is causing this issue. I’m unsure of what extensions you may be using and I’m not familiar with Xamarin so I cannot be sure. Would it be possible to try removing these extensions to see if they are the cause?

Morning ill get a list together of what extentions i have on and see what happens when i remove some of them

most of them should be straight forward but ill post a list in a bit

[2/10] Resource ModuleVersionResource.rc.inl <~ this seems to be the last thing before the app breaks any other toughts ? regards

Okay after unistalling all of the add ons vs refused to open but i see that if i open the project files (.vcxproj) it open is vs 2015 without a problem
for now i can build projects is there a way i can make UE4.9.1 work with whatever ide i choose ? seems like its alot more stable with VS 2015

Our current support for VS2015 is limited as its compatibility with the engine is experimental as of now. If you’re not having any issues with it then I don’t see a problem but it may be preferable to try a fresh install of VS2013, as it won’t open anymore. Have these extensions and addons haven’t been added to your VS2015 installation?

Edit: When you mention that “vs refused to open” do you mean that it gave an error of some sort when trying to open the .sln file for project or does Visual Studio 2013 itself have issues opening at this point? If not, are you able to open the project from inside Visual Studio 2013 instead of trying to open the .sln directly?

vs refused to open it just hung on the loading process
but open in seconds on vs 2015 im actually thinking of using another version of vs2013 since we have pro and premium
might be a mix up somewhere also got a few build errors on 2015

usually with build.bat exiting with code -1 ?

i did do a fresh install as well and it didn’t work either

and yes all extensions from vs 2013 are also on 2015

and for normal c++ and c# development everything seems to work fine only having issue with unreal for now

im planning on doing a format in a few days so if all else fails ill do the format if we don’t get this right if it works then i will report back here

Hello Hugo_PetersNHTV,

It doesn’t seem like your errors are related to the same things but I’m also unable to see the full error. Could you make a separate Answerhub post about this issue in the Installation & Setup section? We’ll be sure to assist you with this problem, but it would be best to keep this post on the same topic.

Ah, I think I finally found someone with similar issues as me.
On my laptop everything is working as expected, but on my desktop I just can’t get it to compile. I do have extensions such as Xamarin installed on both my laptop and desktop.

I’ve been trying to get more info on this error - usually there’s always some info - but I couldn’t find -anything- about this one… this thread is literally the only search result I could get…

I might also go into formatting and upgrading Windows, but it would be nice to get this working anyways, as I don’t have much free time to perform the format and re-setup everything.

Hey ,

Hmm. The errors that I get are exactly the same as the ones in the original post. If you right click the image and select ‘Open image in new tab’ you can see it at full resolution.

The main ‘error code’ that JEMSTUDIOS1 and I share is:
‘DBSBUILD: error(3944377b-ef13-434b-b47a-6fc8c101aeff,2): could not get full path for tool -q’

Just in case, here’s the log in text:

1>------ Build started: Project: PhotonTest, Configuration: Development_Editor x64 ------
1> Performing full C++ include scan (building a new target)
1> Creating makefile for PhotonTestEditor (no existing makefile)
1> [1/15] Resource PCLaunch.rc
1> [2/15] Resource ModuleVersionResource.rc.inl
1> DBSBUILD: error(976aaf12-69dc-4855-9c91-8194485b248b,8): could not get full path for tool -q
1>ERROR : UBT error : Failed to produce item: R:\Repos\NHTV\Y2P21\Y2015A-Y2-CoverShooter\TECH\Networking\PhotonTest\Binaries\Win64\UE4Editor-PhotonTest.dll
1> Total build time: 6,76 seconds
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets(38,5): error MSB3073: The command ““R:\Data\Software\Unreal\Epic Games\4.9\Engine\Build\BatchFiles\Build.bat” PhotonTestEditor Win64 Development “R:\Repos\NHTV\Y2P21\Y2015A-Y2-CoverShooter\TECH\Networking\PhotonTest\PhotonTest.uproject” -rocket -waitmutex” exited with code -1.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Do you still want me to make a new post?

This seems like exactly the same post i have

but i have been playing around and might have a small fix u can try

i suggest backing up this folder


okay so here’s what i did at least i can build now without errors

firstly we need to give the unrealbuildtool admin rights

\Engine\Binaries\DotNET navigate to this location go to unrealbuiltool.exe and right click and say run as administrator

save it double click to see if it pops up the all mighty yes no

now we do the following

As i did build a few html pages here and there i noted that the bat files used for building the unreal code uses "….." or "…" for some reason my pc wont allow this to ever work even when i was building html pages that my pc doesn’t like this one bit

anyway the way around this is to edit the buil.bat in batchscripts
now give it an absolute path in my case
it should be quite easy to know what path to put where in the bat file

i can say after doing this my unreal engine would build fine (Github source) but i would highly suggest that something about the bat scrips be done as my pc kept complaining about the scripts being malware

maybe inherent the locations needed by some c# or c++ code

ill still be playing around because my vs 2013 still doesn’t want to work with UE4.9.1

next up is a clean format and install
if this doesn’t work ill be digging in the source code to see if i can find a way to perform something similar to one click just to get all the possible executable to run with admin rights


PS please let me know if this works

Hello Hugo_PetersNHTV,

I apologize, I didn’t see that similarity, I was looking at the other lines such as the one with Microsoft.MakeFile. Have you been able to give JEMSTUDIOS1’s suggestion a try? I’m continuing to look into the issue and I’ll get back to you both if I find out anything or require more information.

Still not working on 4.9.2 either

please let me know if u need me to help get to the botom of this problem so we can sort this



okay so after doing the build script as i stated above i got past that error of exiting with -1

the dll itself is still missing but i belive its because i havent touched the rebuild script

ill see what i can do on my sid ethen maybe make a small app to apply the same settings as i have here to Hugo’s pc ill keep u updated

@ has there been anything from your side on how to fix this as i got no where with my idea

Unfortunately I haven’t made any progress as of yet. I do have a few questions for you however.

  1. Have you tried any previous versions of the engine or reinstalling the version you’re currently using?
  2. Have you always had these errors with UE4 or did they start at some point? If so, when did they start?
  3. I don’t believe it was ever mentioned but what version of Windows are you using?
  4. Are you using a binary version of the engine (downloaded from the Launcher) or a version compiled from source code?

@anonymous_user_d48836d9 Sorry for the late reply… haven’t really had time to look into this unfortunately, so haven’t tested your methods yet. I will in the upcoming weekend!

@ To answer your questions:

  1. I tried reinstalling UE 4.9.1, but didn’t change anything.
  2. This error has been here ever since I installed UE4 on my desktop.
  3. Full DxDiag log of my desktop can be found here:http:///veus37kz
  4. Binary version. The source code fails to setup while downloading dependencies…

Hello Hugo and JEMSTUDIOS1,

It seems that based off the error (DBSBUILD: error(3944377b-ef13-434b-b47a-6fc8c101aeff,2): could not get full path for tool -q ) that you may have SN-DBS installed. If so, this could be causing issues as it has for a few other users in the past. Can you try uninstalling this and seeing if the issue persists?

i do have it installed i will be unistalling it now and letting you know
if it works


Thanks so much ! This indeed fixed the issue for me :smiley:

I agree with @anonymous_user_d921199a

it works perfectly now and with vs2015

thanks again @

solved this can now be closed

If you wish to continue using that software, I believe you can use version and then the extension SN-DBS-VC-Extension-2013v1.0.7.0.exe without issues.