Download

[Solved] Vehicle Skeleton (Duplication)

Hello All,

I was wondering what would be the best way to duplicate a Skeleton for a vehicle rig to be used on mutiple different vehicles. I currently have my setup with a variety of vehicles all using the same “Default VehicleSkeleton” which all works well and animations for wheels, suspension and other bones/envelopes are all working fine, however…

When trying to use the Skeleton that is imported with a created vehicle mesh the animations seem not to function, all references for this skeleton and physics assets are correctly configured form what I can see, I’ve tried many ways to get each skeleton separate and belonging to it’s own vehicle and cannot seem to get this to function correctly.

Even exporting this original mesh what is working in UE4 into Max and back out, this Skeleton seems not to show any animations at all.

Any ideas please ?

Well guys, I’d really appreciate a few pointers here, so frustrating at the moment, here is what I have done so far and still… I cannot get any vehicle animations with my own Skeleton :frowning:

Firstly
Tried “ReImporting” original skel_mesh from max which I’m sure is setup correctly - Works with “orginal skeleton” - Animations Do Not work with new skeleton
Tried “Importing” totally fresh mesh and skeleton - Animations Do Not work with new skeleton

Secondly
Created everything from a fresh start.
Imported Mesh/Skeleton
Created Physic Assets for Wheels & Body (Just like original advanced Vehicle)
Created AnimBP for this vehicle with all bones setup correctly inside the BP editor
Assigned each specific to the mesh i.e Mesh/Skeleton/Physic/AnimBP

Still I cannot sem to get my anims working correctly, the vehicle moves fine but nothing is animating i.e wheels moving steering turning or nothing, guys throw me a bone please :slight_smile:

Ears open and throw that advice at me if you don’t mind, I can provide any max/files needed to get this one nailed as its the only thing I’ve been going round in for a few weeks now, Originally I thought I’d cracked it as all was working fine but then realised that my newly imported vehicles were all based on the same skeleton which really isn’t going to help me in the long run hence I’ve spent a while now investigating into what is going wrong.

Cheers guys.

did you select your anim BP in your vehicles BP? or have you checked for spelling mistakes?(I’ve done that:p), that’s the only things I can think of right now that would let you drive it but not animate it.

noy quite sure what your trying to do but it should work the same as with chararcters , its just another type of skeletalmesh,

  1. import main vehicle + skeleton, set up physics asset and animbp
  2. on import of extra vehicles make sure you select the skeleton of the first.

this should work fine for vehicles that are very simular eg cars , suv , buggys

if you require different rigs then you have to do the whole thing from scratch for each vehicle.

if you just have add-on’s like arieals/flappy bits then the new bones will be added to the main rig on import

Hi Gents,

Much appreciate the input here as It’s been driving me up the wall (literally with no animations) :).

++FIXED++ about 20 minutes ago and just finished setting up a few vehicles to make sure it wasn’t luck and got the emails for both of your replies so - Thank You Both.

I had not selected the **AnimBP **in the main Animation Tab Settings, I had been choosing the correct skeletal mesh but not the anim, so obviously my animations wasn’t going to work. It hadn’t even occurred to me neither but I knew it was going to be something simple as I had gone through everything for 3 days with a fine tooth comb :slight_smile: apart from the bit I needed. What triggered it for me is I read a thread regarding “is your viewport in realtime” and I thought mmmmm but no mine was so at that point I was sifting through every possible options and setting that I had not played with before.

I feel like the grandmaster @ vehicles now lol as every stone has been unturned over 3 days :slight_smile:

Screenshot below with options I didnt select (silly me).

Capture.PNG

Thank you both very much for your responses here, it’s very much appreciated - And now… to continue my project.

Can this thread please be renamed as [Solved] - Thanks

just click on edit at the bottom of your first post :slight_smile:
then change the title

Done that but… It only changes the title inside the thread mate, needs a MOD to change the Topic Title in main Forum View

nope doesn’t work for me either :frowning:

guest i"ll have to report it to the forum team.

yeh title fixed

Cheers GeoDav :slight_smile: