Download

[SOLVED] Unreal don't see Visual Studio 2017

I installed Visual Studio 2017, but Unreal don’t see it. When i install 2015 Unreal sees it, but i need the 2017 Version.
I have an issue with the registry key…How can i fix this?
The others with15.* are empty too…only in 14.* there are entries.

I found here something, but i don’t know what to do:
https://answers.unrealengine.com/que…to-change.html
I got not these errors. igot, that unreal wants me to install visual studio, but it is allready.

Can’t create c++ Classes/Projects

The Build is successfull: See Picture

My Visual Studio Version: See Picture

My C++ Version: See Picture

where is this variable, and have it something to do with my problem? Have i problems with variables?
%VsComnToolsPath%

Global Variable is set: See Picture

See the Pictures…there is my Project Settings for UE4 Source Build

See Picture: My Folders on C:

Yes, i really got a problem, and i don’t know how to solve it…I deleted visual studio again with InstallCleanup.exe -full, i deleted folders that where left. The Installationfolder, the AppData Folder, the ProgramData Folder. I deleted the registry keys. Than i installed visual Studio from the supported Side.
Unreal don’t see it.
When i run Generated.bat -2017 cmd says that visual studio is not installed. Than it tries to install with visual studio 2015, which is not installed.
Here are the Pictures from gegedit. Only what you see is there. All the othher Folders are empty.

Edit: when i try to run UnrealVS.vsix, than nothing happens. The cmd pops up extremly short. Than it closes again.
I set the Environment Variable VS150COMNTOOLS (see picture)
I installed Buildtools for 2017. Than a Folder 14.0 where created…i set the Variable VS140COMNTOOLS

The Problem is with the registry Keys…