[SOLVED] Unexpected program state

It happened several times with this project :frowning:
Usually it fixes when I re-run alignment. (Edited: its not fixed, it keeps failing at 33% “processing stage” or so)

Sin título.jpg


The project has:

96 LSP files (converted from PTX)
2.197 50mp JPGE photos

Hi Manuel,

the program issue seems to be related to the image part of alignment.
Are you JUST importing the images or setting/changing anything before running the ALIGNMENT ?

I’ve tried to process the images separately: It works
I’ve tried to process the laser data saparately: It works

However when I mix them it throws that error.
This is what I did:

  1. Change the settings to the ones you usually suggest
  2. import LPS
  3. import Images
  4. Run alignment.

Hi Manuel

  1. Change the settings to the ones you usually suggest

Did you change the alignment settings or not?

When you have aligned the images and laser separately, then it is OK and you can use even more powerful workflow with COMPONENTS.
Open the project where you have the images, in alignment use SELECT ALL cameras, next to it is the REGISTRATION tool, use it and export cameras as a RC COMPONENT. It will export the alignment with JUST the points used in the actual ALIGNMENT. Then you create a new scene, and in the WORKFLOW tab, next to laser imports is the COMPONENT import tool. So import the COMPONENT you have from images, load LSPs and hit align. This workflow is even faster and more RELIABLE for alignment of bigger datasets…

Try it and let me know…

The thing is that I am struggling to align all the images toguether in one component, I was hoping that the laser information could help it align better. Cab I export several components, import them in a new project and align them with the LSPS? Should I set Merge components only to true?


Hi Manuel

just import the COMPONENTS and hit ALIGN, you do not need to play with other settings…

Oh well I’ve just tried to process the stack of 2.2k images again (just the images) and the unexpected program state happened again, I tried to isolate the images just to check that I didn’t have any corrupt file and its working fine, however when I join them toguether and process them it fails… strange! :frowning:

Edit: And this is even more strange, I reopened CR, put the 2.2k images again in, aligned and it worked… no unexpected program state, so I guess its not because of image data corruption :?:

HI Manuel

I’ve tried to process the images separately: It works

As you are saying, you could manage to get all the images aligned before, if you have saved it, just try to use the COMPONENT workflow.
The unexpected state – can you inspect images whether you do not have few of them captured too close? Meant as “stereopairs”, that could cause the issue…

Hello Wishgranter,

That might be the cause (images taken way too close to each other, or from the same position just tilting the camera)
I am trying to align the photos with the laser following this workflow, is it correct?

  1. Align photos (Im getting 3 big components)
  2. Save each of them as component
  3. Open new instance of CR
  4. Import 3 components
  5. Import laser LSPS
  6. Hit align without changing the settings

And the problem…

  1. Nothing is being aligned, im getting a duplicate of the 3 components plus the laser images, I am doing something wrong? Should I change the settings? (The laser information has the totality of the object, so it should help align the smaller sections right?)

Sin título.jpg

Any ideas?


Hi Manuel

Can you better describe what the results from this sort of data should be?

From my view of the data you have used, laser scanner can get say 1mm scan resolution and then add IMAGES to increase the quality of mesh and textures, but the workflow is a bit flawed then…

What camera + lens have you used?

I want to get a full scale representation of a tree at the highest resolution.

The whole tree was scanned with a faro scanner and then the trunk was scanned with more detail using photogrammetry. I thought that the laser data would be useful as well to help align the details of the trunk toguether.

We’ve used a Canon 5DSR and a very high optical quality Canon 100-400mm lens.

Hi Manuel

In short, what is the scanning resolution of the scanner ?
What GSD are the images ??

Wishgranter wrote:

Hi Manuel

In short, what is the scanning resolution of the scanner ?
What GSD are the images ??

GSD = ground sample distance?

Do you mean the size of each pixel in relation to reality?
This is the FARO scanner that was used FARO Focus x 130
How can I look for the GSD?

“The ultra-portable Focus3D X 130 enables fast, straightforward, and accurate measurements of objects and buildings. It records architectural façades, complex structures, production and supply facilities, accident sites, and large-volume components.”

Distance accuracy up to ±2mm
Range from 0.6m up to 130m
Noise reduction 50%

Found this could happen due to CPU overheating, in my case, just opened a pc case door, and alignment went with out an error.

I have the same problem on the alignment phase. 689 tiff images. What it coluld be? Thanks! 

please do not post duplicate posts: https://support.capturingreality.com/hc/en-us/community/posts/115003218091