Download

[Solved] Totally Unable to Generate XCode project files - 4.12.5



Setting Up Mono
MSBUILD: error MSBUILD0000 : Project File '../../../Source/Programs/UnrealBuildTool/UnrealBuildTool.csproj' not found.


We’re getting this error whenever trying to create XCode project files for a 4.12.5 project on Mac. An identical project works 100% fine in 4.11, as we’ve done so before.

We’ve tried disabling all our plugins and everything - We’re using binary (launcher) version of the engine. We’ve also downloaded absolutely everything for it from the launcher.

Answerhub. Posting here too because we really need to sort this today!


After some searching I found this post on Issues linking to this answerhub post.

In that post, it says the issue is less serious than it looks and that the files are generated properly - but this is NOT the case for us, no files are generated at all.


After copying a fix from here: we not get this error:



UnrealBuildTool Exception: ERROR: Expecting at least one ProjectTarget to be associated with project '/Users/ne176925/Perforce/OBickmore_StormtideMac/Stormtide/SatSim/SatSim_Main/Intermediate/ProjectFiles/GESGame.xcodeproj' in the TargetProjects list 


…wut?


FINALLY fixed it. Turns out Perforce was being a little sod and not correctly pulling our Target.cs files.

I’m gonna go lie down in a corner now.

Glad you got this sorted out, man!

Sigh Always the way, assume it’s the engine - turns out to be third party tool…