[SOLVED] Texture error steam1.0.2.3008

 I’ve made a model from video images, and the model and colorized points look good.

But when I texture, a few portions come up as large blotchy patches, that don’t really represent any of the source image or mesh points. I’ve loaded a couple of the source images on the left and tried to show most of the texture settings.

Hi Jennifer,

is it possible that there is a problem in the mesh there?

Too large triangles will not be textured…

Hi Gotz

No, if anything I have a small triangle problem - surface noise continues to plague our casually captured scenes. (In this case the images are from iphone video)

Here is the solid render:

And the sweet of the same area 


I did think maybe it is unhappy about the reconstruction bounds but as far as I can tell, I’m not trimming off any surface triangles - and mesh/solid looks intact…

Hmm, there have been other reports of difficulties with texture lately.

Maybe it’s all tied into that.

Did you play around a bit with texture resolution or did you simplify the model to see what happens?

I’ve re-aligned and re-made both the ground plane and reconstruction region.  Interestingly, a colleague was benchmarking this same photo stack on an Azure gpu server with a fresh install of a demo licence and didn’t have any problem with the render.  It looks like it decided this area was clipped/back end on the reconstruction… but the surface mesh says it had lots of dots/features to work with.

Anyway I think it’s rendering better now (just in the middle of a run atm)

If that works, I’ll let you know how we go after simplification etc.  Thanks for the suggestions

yes - so somewhere between adding photos, playing with the texture weights, re-aligning and then re-do ground plane and region box it seems to have fixed whatever RC was stumbling over…   Here is the correctly textured region

Looks much better! 

Glad it worked, whatever it was…

You working late down there?  :slight_smile:

Looking at the last clip, the splog on the dirt where it changes to red is still flat shaded.  But at least the problem is away from my working area now!

Not late (just 4:30 now in Perth) but this was a longer task than expected…

Thanks for the suggestions and general encouragement Gotz