[SOLVED] Teleport issue with intersecting geometry

Hi! I’m trying to make a function that reset the vehicle orientation when it roll over. So far, I were able to determine when to use it (the vehicle is not moving and the rotation of tow axis is higher than 80). So I guessed the only thing I need to do is just teleport the actor to the same location (plus some added z units) and reset two of the axis. But I’m getting the following error:

LogPhysics: Warning: UWorld::FindTeleportSpot called with an actor that is intersecting geometry. Failed to find new location likely due to movement component’s ‘UpdatedComponent’ not being a collider component.

I’m no very familiar with programming (just the basics), I’ve ben using blueprints and almost searching for everything, so I’m not sure what is the meaning of “UpdatedComponente not being a collider component”. This is the part of the bluperint I’m using to set the new location:

Hey! It worked. Actually, not exactly, if I’ll do it as you tell, I get the following message:
“PIE: Warning: Attempting to move a fully simulated skeletal mesh VehicleMesh. Please use the Teleport flag”
So my issue is I didn’t realice the only thing I needed to do is check the Teleport bool, and I missunderstand I had to use the Teleport function instead. So I did it like this:

Man, thanks for you fast response, and sorry for my english.

Awesome community!

Can you test it with this node instead, leaving the Teleport bool [edited] Ticked:


Are you getting the same (odd!) message?

Essentially, the Teleport node actually checks for valid space and it might be freaking out for a couple of reasons.

Makes sense, actually. Wasn’t sure how the vehicle was set up. I’ve amended the answer to avoid confusion, thanks for pointing it out!