Solved Niagara Ribbon culled clip glitch

, ,

Continuing the discussion from Niagara ribbon renderer + beam bounds issue:

Hey, I’m just making this post as I had this problem, was barely anything via google and couldn’t reply to the similar post for the problem I had. Posting so someone with this problem might find this via google. :stuck_out_tongue:

I had problem with ribbon niagara effects clipping when the start->end vector was in certain angles (all emitters of that appeared/Reappeared whenever I spawned any ribbon in that direction). Also was clipping when using these effects with tons of enemies :D. The reason was as I understood it that as the ribbons are cpu, so fixed bounds dont work with them and they can easily get occlusion culled. So what worked for me first was disabling occlusion culling, but later on I made sure that when spawning my niagara emitters, the scale is at least 1 instead of default 0,0,0/zerovector, that made all my vfx stop getting culled. Hope this helps someone in future.

So this is basically solved, no clue how to mark it myself :P.