Download

[Solved] Make UE4.25 use VS2019 instead of 2017 - Editor Preferences are set to VS2019...

Hi,

i have Visual Studio2017 and VS2019 installed on my system. I changed the Editor-Preferences to VS 2019, but UE4.25 still runs VS2017.

I don’t want to delete VS2017. Is there a way to register the filepath of VS2019 to UE?

Thanks!

EDIT:

Solved it accidently myself:

  • Close VS & UE
  • Delete Project Folder: .vs, Binaries, Intermediate, saved and *.sln
  • Rightclick *.uproject -> Generate Visual Studio Project Files

Now VS19 will run if Setup in Editor Preferences.

2 Likes

Nothing in this thread worked for me. But I did find the problem on my end and the solution:

  • Make sure when you have for example VS2017 and 2019 both installed, that you’re using 2019 with UE4. This can be set in Editor preferences → Source code → Set source code editor to Visual Studio 2019 instead of the default “Visual Studio” or “Visual Studio 2017”
  • Close editor. Then delete the followign from project folder:
  1. .vs
  2. Binaries
  3. DerivedDataCache
  4. Intermediate
  5. Saved
  6. .sln file
  • Now right click on .uproject file and select Generate Visual Studio project files"
  • Right click on .sln file and choose “Open with another program”
  • Select Visual Studio 2019 and check “Always open .sln files with this program”
  • Double click .sln file to open it with VS2019
  • Open the new actor class you created (the .h file)
  • Where it says UCLASS() → make this UCLASS(Blueprintable) (this step might not be necesarry but makes sure it is exposed to blueprints so the editor has at least 1 c++ file that’s exposed to blueprints).
  • Right click on your project name module in the solution explorer → Set as Startup project
  • Make sure your environment is set to “Development” and NOT “Development Editor”
  • Press F5 to build and run the editor.
  • The C++ Classes folder should now be visible in your content browser, If NOT, make sure you set to display C++ classes in view options and expand the content folder list with the button in top left of the content browser.

That should fix it!

The problem on my end is that when I created a new C++ class I choose “None” to create an empty class. The problem is that this is an empty class and it doesn’t contain any code that exposes it to blueprint. Which is why it doesn’t show up in the editor. To solve this, instead of making your first C++ class an empty “None” class, make an “Actor” class instead which can be exposed to blueprints.

Hope this helps!

1 Like