Download

[Solved] Magic Leap (Lumin SDK) breaks Installed Builds / Build Graph in 4.20

I can’t currently compile 4.20 release branch into an installed build using Build Graph. It seems every major release there’s an issue which prevents Build Graph from working properly. I’d Answerhub/bug report this but I’m kind of in a rush.

Apparently theres’ “No Build Platform” for Lumin (which a quick google reveals is the Magic Leap SDK). Any clues on a fix for this?

Alrighty, turns out Magic Leap is identified as the “Lumin” platform in UE4 and is a completely independent platform. You have to explicitly set the command-line flags for UAT so that it doesn’t try to build for the Lumin platform. You can do this by either using the HostPlatformOnly flag or with WithLumin = “false”

Thank you.

There are instructions on how to setup the SDK for already built engine here: https://docs.unrealengine.com/en-us/Platforms/MagicLeap I don’t know if it would be enough for a custom build.

So I found another solution if the unreal your building is not for magic leap stuff, delete the Limun plugin folder in Engine/Plugins. release branch only though, master is building just fine(for now)

if this is wrong please enlighten me

You don’t need to delete the plugin. Just use the switch. Here is a batch file I use to generate the install build we use for most of the projects here. It sits in the root directory of my UE4 folder.



echo off
cd Engine\Binaries\DotNET
AutomationTool.exe BuildGraph -target="Make Installed Build Win64" -script=Engine/Build/InstalledEngineBuild.xml -set:WithDDC=true -set:SignExecutables=false -set:WithWin64=true -set:WithWin32=false -set:WithMac=false -set:WithAndroid=false -set:WithIOS=false -set:WithTVOS=false -set:WithLinux=false -set:WithHTML5=false -set:WithSwitch=false -set:WithLumin=false
echo.
echo. Generatation Completed.
pause


I use this, it’s quite a useful tool by RyanJon. I’ve added a few toggles for Magic Leap, PS4, Xbox One, Switch etc. EDIT: Looks like I need to update the Magic Leap PR unless he’s added it already.

Also RE the above post, I believe as of 4.18/4.19 or so, you want to be calling AutomationToolLauncher.exe - I ran into some issues with it trying to copy files that were in use during packaging. [USER=“1384187”]Joe Wilcox WisE[/USER]

Really, I’ll haven’t had any problems cooking as of late. Honestly didn’t even know there was a stub in existence. Thanks for the heads up.