(SOLVED) Level won't load on Android

Hi there,

So lately I’ve developed an android game, and it is fully functional on PC, however when I transfer it to my phone as an APK file it runs but doesn’t let me access the level. The buttons are all there and you can leave the game, but there’s no way to start the game as the button does nothing when it’s tapped. I’ve checked my setting and they look fine, the button also has the event set and it fully works on PC so it should work on Android too, but nothing happens.

I was thinking that if the game was not function and if the touch interface didn’t work then I wouldn’t be able to exit the game, but exit works fine.

What can I do? I’d like to get some advice if possible, the game I’ve made is an endless runner game. I’ve tried looking for solutions on YouTube but other developers seem to be having the same issue after the update of their Unreal Engine.

Do you get any errors? Have you selected your game default map in the settings?

I had this very same issue. I was ripping my hair out for a LONG time.

I am going to make two assumptions here;

  1. You have an android device running Android 10
  2. It works on other peoples older devices that are running Android 9 or below.

I changed the target from 29 to 28 and mine now works on Android 10.

I hope this is the same issue and it helps!


Thank you to everyone that has taken their time to reply, the above solutions didn’t work but I found the reason behind the issue.

It turns out all of my levels weren’t cooking and after selecting everything it now finally functions.