[SOLVED] Issue importing FBX facial animation with skeleton vs assigning to existing skeleton

I’m importing a facial animation (joints and morph targets) but having issues with certain bones.

I’ve exported the “base” skeleton and mesh asset from May and imported into Unreal. Then animated on that asset in Maya and exported for the animation.

If I import the animation file, don’t import the mesh, and assign to an existing skeleton, then some bones (eyelashes and eyebrows) only seem to come in with their rotational values animated, NOT the location values?


If I import as a brand new skeletal mesh asset, do import the mesh, and don’t assign to an existing skeleton then it all works fine!

Other than this issue everything works fine, all other joints in the face and all blend shapes works as expected.

Anyone out there got any pointers?!

Check the retargeting options for the skeleton.
it could be that some bones have their translation retargeting set to skeleton instead of Animation.

It’s about all I can think of - and if May is a paragon character this is also kind of unlikely. They are usually all set to animation as far as I have seen.

a thing to note though.
If you added morph targets and bones to get new details in, then the original mesh won’t have this data and you do need to re-import it get it to work.
if you just animated stuff that was pre-existing, then yes it should just work when you import the animation.

OMG [USER=“3140864”]MostHost LA[/USER] you lifesaver! Yes, I had set the majority of bones to Skeleton for retargeting purposes, but these particular bones aren’t needed for that, so setting them back to Animation worked! I hadn’t even thought of that. Thank you thank you thank you!!

No worries. I hate that setting for the same reason :stuck_out_tongue: