Download

[Solved] Intellisense cannot find source files in new (untouched) project

I am having problems getting intellisense to work, even in a brand new (completely unedited) project. I can tell it’s intellisense because the project builds and runs fine but the error log is constantly filled with complaints about missing generated files (see image below). This problem also happens in my other projects as well.

This is definitely a major problem because it renders live error checking completely useless. I’ve already tried deleting all the folders I can and regenerating the project files multiple times. Currently I’m using VS 2017 and this happens in 4.19.2 and 4.20 preview 5.

Another annoying issue is that I can’t click on C++ files in the editor to open them because I will see the “Loading Visual Studio 2017…” toast forever. This also happens in 4.19.2 and 4.20.

This is a less important issue than losing any ability to error check, but is still frustrating. I’m surprised using VS2017 with UE4 feels so undercooked this far into the development of the engine.

**EDIT 2: We did it! Epic will be introducing a fix for this problem in 4.20.3!

EDIT: Please vote on this issue so we can get an actual for fix for this issue. Currently Epic has this problem as “Backlogged” so every vote counts.**

In this video I explain the solution to this problem. If you want to see the old solution check out my post on the Answerhub.

The following are the include paths that you need:

I hope this helps anyone who comes across the same problems!

Thank you very much. I got the same issue after I started using 4.20

Unfortunately, this doesn’t work for me. I still get the same errors. Any other ideas?

p.s. also, if I understand correctly, every time, I am going to click on Generate Visual Studio project files I’ll have to repeat these steps right? Because the include paths get overwritten if I am not mistaken.

EDIT: actually, looking at your screenshot, I see that my Evaluated values are different. Is that maybe because I installed UE420 on a different partition?

EDIT2: I can confirm that changing these entries so that Evaluated values correspond my system worked. Also, I had to add directories for my C++ plugin (BP Function library). And also, I can confirm that this whole procedure has to be repeated everytime you Regenerate VS project files. Pretty annoying must say…

Not sure how much it matters but OP had posted something that wasn’t QUITE right for me

In the beginning of the BIG copy/paste you need to do there is:

$(SolutionDir)\Intermediate\Build\Win64\UE4Editor\Inc$(SolutionName);

Which should be

$(SolutionDir)Intermediate\Build\Win64\UE4Editor\Inc$(SolutionName);

Because for me at least $(SolutionDir) included the \ in it, so I ended up having a “path\path” and that caused it to not work for me. Eliminating that \ between solutionDir) and Intermediate made the whole thing work for me.

Yeah I ran into the problem of having to redo the procedure every time you regenerate VS project files as well. Honestly I went back to 4.19.2 because the amount of annoying problems I’ve run into even after this fix isn’t worth it.

Nice catch, I looked into this and it seems like you’re right. Not sure how that was still working for me originally but I’ve updated the post and fixed this. Thanks again!

Thanks. I voted for the bug, but I think I’m gonna go back to 4.19 for now as well. Its just such an annoying problem that it’s causing various other issues.

Hopefully will be hotfix’d and not have to wait for 4.21 or 4.22

This fix doesn’t seem to be working for me.

Apparently there is a “;” missing after CoreUObject

Another nice catch, I’ve edited the original post. Also, I double checked the paths and I didn’t see any more mistakes like this. Thanks for your help!

P.S. Luckily now that Epic will be patching this in 4.20.2 we wont have to rely on potentially error-prone include lists anymore. :slight_smile:

For those suffering this bug, what do we need to do to a project after updating to 20.2? Will the included paths be fixed on an already started project, or does something need to be done first?

based on the issue page, it looks like target fix is 20.3, not 20.2

Intellisence still can’t find few .generated.h files… Controller.generated.h, Pawn.generated.h, SpringArmComponent.generated.h, MovementComponent.generated.h, CameraComponent.generated.h and so on.
Atleast not for me :slight_smile:

BTW don’t you know why Intellisense shows me “Pointer to incomplete class type is not allowed” error? Also shows warnings for some macros. That wasn’t there before.


$(MSBuildStartupDirectory)

yields a different path depending on where you launch VS from. ie. if double-clicking the sln file in the project dir. that dir will be used. which will make it not work.

I had to go through the string and replace all occurrences of


$(MSBuildStartupDirectory)\..\..\

with my actual UE dir


D:\UE_4.20\Engine\

This bug was fixed in 4.21.X but it started happening again in 4.22

https://answers.unrealengine.com/questions/885746/generate-project-files-in-422-does-not-add-intelli.html

Any advise how to solve this problem ? I am on 4.22.1 and I see red underlines everywhere !!

4.24.1 problem cropped up again… the solution posted here only solves half of the includes.

you have to delete .vs folders for project. then generate project files again to repair. had to do it 3 times before it actually worked.

And it appears agian in 4.24 with VS2019

This problem started for me with the 4.24.2 hotfix using vs2017 :\

Intelisence doesn’t work. Never has. Its a feature that Microsoft has tried to steal from Whole Tomato. I recommend you get the original from them. Its called Visual Assist. And they are unfairly being put out of business by Microsoft attempts to replace them with half ■■■ implemented feature set.

Turn it OFF, and buy Visual Assist.

Unreal is an “External Build” solution. Nothing about Visual studio has any knowledge of what the “External Build” process looks like. Therefor there is NO WAY Microsoft can fix Intelisense, or get it working. Its only there the prevent Visual assist from functioning properly.

Hi, This same error appeared to me in UE 4.24.0 and VS 2019. Unable to acces source file…

This fix worked for me: Inside Vs, in the top toolbar click Project -> Properties (Bottom option) -> VC++ Directories -> Include directories -> edit -> It will open browse menu, in there point it to : example. D:/UnrealProjects/“YourProjectName”/ Source/“YourProjectName”/Public

After that the header error was gone. Only thing left are the errors regarding pointers. “Pointer to incomplete class type is not allowed” but it compiles and runs fine with that displaying.

Hope this helps anyone who gets this error in 4.24