[SOLVED] Imported animation from Blender are really tiny

When I import an .fbx (with animation) from Blender, the animation becomes really really tiny I tried with everything but the animations (no only for the bow, any animation) is imported like that So, I don’t know if you had the same problem an I don’t know if the problem is on the importing of the fbx or on the exporting (from Blender 2.79) (UE4 4.18.2)

If it’s needed I can upload here my .blend file of the bow

(Check all 5 images)

226167-screenshot-168.png

Make sure you work in the right Units (cm) and also export as cm. 1 Unreal Unit = 1 cm.

Make sure that your Reset your Transforms to 1 (I belive the Shortcut is ctrl + a)

This kind of errors usually originate from scaling. Imagine you import into Unreal with a scale of 2 but Unreal converts it to its original scale of 1 so it basicly halfs it in size. Its does it all across the Bord from Mesh to animation etc. If you got trouble to figure out test it on a Dummy Mesh like a Tube with 3 joints and see what is affected by what. It´s worthwile to understand the pipeline to avoid running into strange things again. Also worth noting is that Unreal does not understand Modifiers (there are to many across 3D modeling Apps) so make sure you bake them down and export without any Modifiers at all.

Also small disclaimer Im not a Blender user but the above applies to all Modeling Software the terms vary here and there.

Hi,

Did the answer below solve this issue for you? If you are still running into it I can take a look at it but will need more information such as export and import settings.

-Thank you

I resolved that, I had to change the name of my armature (bones), without keeping the name of default that is “armature”

Answer from a boy of Discord Channel “Unreal Slackers”:
There seem to be a thing that if you name your armature “armature” it doesn’t include an extra root bone ( where the actual root bone is parented to that ).
So after some reading it seems like because Blender adds an extra root, I’m assuming the scaling also relies on that. So when you use armature as name and the additional bone isn’t added in unreal the scaling is lost. But I can’t be too sure of this.
There is a UE addon for blender that does some exporting for you.

This was the answer for me… crazy that leaving the default name would affect this so much… I imported and reimported with different scaling settings so many times trying to figure it out. Thanks!

Hi thank you for your answer, however after renaming the armature object and bone to something else, my animations are still tiny in Unreal 4. I’ve been at this for several hours with no luck. Anything else you recommend I could try?

I’m baffled. Renaming “Armature” to anything else, fixed a major animation scale problem to UE4.

July 2020 and this problem is still not fixed, someone said to change the Scene Units to 0.01 but that only scaled down the Skeletal mesh to the tiny animations as well. And you might think… “Fine I’ll just scale it up in the blueprin-” WRONG. Just look at the generated phat, it’s 1 blob.

Thanks a lot!

EDIT: @AssassinNation, 1 year too late, BUT, for anyone else reading this… the problem might be that the armature doesn’t have scale transform applied. But don’t quote me on that.

I’m facing this issue too… Any help ?

Make sure in export settings to change Armature FBX in the Armature settings from null to root.

Hello/Bonjour !
I changed the name of the Armature and it worked !! thank you su mush!!

One other thing that worked for me, using fbx exported from Cinema 4D, I’d parented the mesh and rig to a null (for being tidy). All scale was set to default 1, until I unparented from the null, and the root bone scale then reset to 100. I think this is because I added the root bone after I’d already frozen the scale transform of the null. So to fix this I unparented the hips/pelvis from the root, froze the scale transformations on the root, then reparented. Exported without the null. All works now.

In case this doesn’t work, another solution is to use Autodesk FBX converter. This is free software from Autodesk. It corrects some of the issues that may arise from creating the armature from blender or user. I have tried many solutions and this one works for me. I would recommend doing this first before trying any other solution. No need to change any settings both in Blender and unreal engine.