Download

Solved (I think): Unreal websites keep changing to Japanese

I’ve seen others have this problem and its been happening to me for over a year without resolution. Only on Unreal website it will frequently change to Japanese despite changing to English and having account settings specifying USA and English.

I would check my browser and see English at the top of my languages list, so can’t be that right? well…

Apparently my browser languages looked like:

  • English
  • Japanese
  • Spanish
  • English (United States)

So if I’m correct and this problem is finally solved, I had to move English (United States) specifically to the top - I guess the Unreal websites (unlike every other site I visit) looks for the English United States language and not simply for English language. So far this seems to have fixed it because it has been really annoying fingers crossed

I had this a while back. Apparently if you viewed the site on Android mobile (note that that means Google account across multiple devices), and you just so HAPPEN to use a Japanese keyboard while browsing, it’ll change you default language on the forums to Japanese and won’t turn them back to English on ANY other device browsing with your Google Account.

Solution: Navigate to the Unreal site ON MOBILE, change the language there, and it should properly change it back on all other devices.

Oh that’s an interesting one - so far mine has been on English since I did my solution thankfully. For some reason Epic really wants everyone to learn Japasese :wink:

i already did this and i am still having this issue. only its a new issue which has only cropped up again (i happened before and i fixed it but the same fix did not work this time) and i can’t get it to recognise to stay on the https://docs.unrealengine.com/en-US/Engine/Blueprints/index.html site, it keeps immediately switching itself without permission or asking to the stupid japanese site. again. i am not japanese, nor do i speak japanese and japanese isn’t even a language choice in my settings.