Download

[SOLVED] how to ignore npc camera collision?

hi, i’m working on a game, i have used the third person template to starting point.

i have a little problem, when my npc (enemy, in my case a zombie) goes near by my player and attack the player, when it overlap the player (collide with it to punch him) the camera moves and the sequence can be viewed because the camera has moved to avoid the collision.

i tried ignoring the entire camera collision, but in that case when the player goes behind a wall i can see him.

i saw the c++ code of the player character and i don’t see (or i don’t know what i’m searching for) anything related to the camera collision.

also tried to move some values in the player’s blueprint but without any success.

i just want to ignore the collision of the camera with my enemies classes to avoid the get away behavior that is happening now to let the player see how the enemie attack him.

if anyone can point to me to a thread or tutorial on how to fix this, that will be very helpfully.

thanks in advance for all the help.

In your NPC collision channel, you have to set it to “custom” + enable the “ignore” for the “camera” :slight_smile:
Now the camera wont collide with the NPC

thank you fighter5347, you saved my day!

fighter5347 i tried the settings you told me on the npc, but still the same, take a look of the video to see the issue still happening after the change of the settings.

also these are the settings that i have changed in my npc blueprint (collision for the capsule and mesh components)

any idea or clue of what i’m missing here to get this working ?

sorry for the bump, but i still need help fixing this issue ? any help please ?

i solved my problem with the camera, if anyone has the same problem, i found the answer here

hope that will help somebody.

3 Likes

It did! thanks enzoravo for coming back and letting everyone know. The trace channel change to visibility solved the problem.

1 Like