Download

[SOLVED] Got unwanted rotation when do stretch and squash animation

So I was testing stretch and squash animation made in Blender, after I import the FBX animation (with default setting) I got unwanted rotation on last child bone (foot, hand, and head).

UE4

Blender

And this is the FBX file.

https://cdn.discordapp.com/attachments/225448446956404738/760245134855634965/stretchTest.fbx

The point is can anyone test the FBX file animation on different animation software (maya, 3ds max, etc) just to make sure that this issue is engine limitation.

Thanks.

Additional Information

Engine Version : 4.24.3

Blender : 2.90

In all likely-hood it’s a blender driven issue even if you don’t see it happening in blender.

I have had to adjust BoneBreaker to exclude parts of the rig from the stretching before. The stretching was causing unwanted rotations of the spine.
In my case the issue was how Blender’s Rigify rig was handling things, but the rotations and odd stretching was caused by blender itself.
Rigify should since have addressed the issue on their end. The blender issue likely persists.

Also, It’s not the Last bone of the chain that is rotating, that would be your mesh Toes, not the Feet.
And Finger tips, not hands.

If your hands are also rotating the issue may be something else that blender is doing. Check to make sure that the animation of the stretching doesn’t change the Roll of the bone(s) as well.

That said, Make sure you are on the latest blender.
I’ll give it a try later today and if I find the issue to be (as I expect) blender, i’ll file yet another bug report on it.

So the stretch constraint is the green box (bone visualization) from spine_01>neck, thigh>calf, and upper>lowerarm
and the yellow bone is copying control bone transform so they wont inherit the scale from parent.

here some test using sketchfab, and looks just fine

Could you also share the blend file?

unfortunately I can not do that, it’s unfinished project.

basically I’m just do some test for stylized animation such as stretch and squash but I encounter this issue and I think I’m just gonna stick with move the bone to get stretch effect.

really appreciate for your response, so yeah thank you very much.

There is most definitely something screwy with the rotations and copy location / copy constraints for bones.
It’s been like that since .28.3

**SOLVED **by changing Preserve Local Transform to true in import setting

You will get error but it’s fine

importeror.png

The result

2 Likes