[SOLVED] Google Play Login window not showing up UE 5.3.2

Hi everyone! I need urgent help with logging in to Google Play for ue 5.3.2. I’ve been trying for weeks to implement Google Play log-in and purchase system, but nothing works. I searched in many forums, as well as in the official documentation, no result. I added App ID, Licence key from Play Console, created and edited AndroidEngine.ini file with following:

[OnlineSubsystem]
DefaultPlatformService=GooglePlay
[OnlineSubsystemGooglePlay.Store]
bSupportsInAppPurchasing=True

Added Play Services configuration in Play Console and published it, including OAuth client ID.
The login logic is set in game instance blueprint, it calls ShowExternalLoginUI, but in game nothing happens, login screen doesn’t pop up and no error is shown up. The game is in internal and alpha test on Play Console. I’d very grateful if someone could help with this problem!

Okay, I finally fixed it. Took me 2 weeks of work and research. So the problem was in target SDK. For some reasons target SDK of 34 refuses to work. Setting it to 33 fixed the problem! If you are having similar issue, check also the following:
-integrate Firebase to the Play Console project, create OAuth Web Client ID and link it in Firebase when adding Google Play Games under sign-in methods
-put google-services.json into /Build/Android/
-set Target SDK to 33

Hope this helps someone. If so, don’t forget to like!

1 Like

Hi , I’m trying to implement googleplayServices but unable to do so. These are the steps I have followed:

i)Enable google play ,added APP_ID , added Permissions.
ii)Created new cloud project for app. I’m using Google Play Signing. I have created Android Credential with Google Play Signing Key and created web-client using Fire-base . Which is auto generated.

even after this the application crashes after calling Show External UI ,and my game is in Closed-Alpha.

Can you give me details steps on how did you setup and make it work. Can you help me with this.

Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.