Download

[SOLVED] Destructible mesh-can't even fracture mesh? and after that can't fracture any other mesh?!

I have a mesh that I wanted to fracture, so I right clicked on it -> Create Destructible mesh.

After I pressed ‘Fracture Mesh’ though, it doesn’t work; in preview depth 0 the mesh is the same regardless of the explosion amount, and in preview depth 1 I can’t see anything.

To debug that, I thought I’d import a cube and see if that works. so I imported a cube, right click -> Create Destructible mesh - and I see the same thing as the picture above, which isn’t even the cube! I even tried restarting the editor, but it’s still happening.

What is going on? what am I missing here?

I have the same Problem and I have Tried a lot of things but still couldn’t solve it. I think its a bug in the new release.

Here is what I have Tried

  • Created a New Project
  • Reinstalled Unreal
  • Created a New Project After Reinstalling the Engine

But still the problem persist, Even though when creating an entirely new project after reinstalling unreal and restarting windows, its the same problem.

Here are some Images of last try when i reinstalled unreal and created a new project with starter pack.

Capture.JPG
After that I right click on SM_chair to create a Destructible Mesh and then this is created

This was the Original Mesh on which i activated the create destructible mesh from a different project. Instead of the SM_chair this mesh appears which is not even the part of the project.

Found a Workaround, kind of a pain but it works. The Workaround does not get the rid of the bug but still it allow to continue working on project.

So Creating a New Project in 4.23 and using it to create all the Destructible mesh then migrating it over to 4.24 project.

still this does not clear the persistent mesh in UE4.24 Destructible mesh editor.

I have this problem too ! Please Epics guys, help to solve it!

I have the same problem. The editor is stuck with the previous mesh I tried to fracture no matter what new mesh i tried to load in. I’ve re-installed the engine and everything. I’ve even removed all the asset files from my local machine. It’s really weird. I also submitted a bug report. If anybody finds a way to clear out the apex plugin please let me know!

Me too same problem.

Same problem here, stuck on the same mesh, no matter the mesh I use.

Same problem,please epic do something,we need a hotfix

Yes, we wait a fix !!!

And…Same problem after updating to 4.24.2:(

I just loaded 4.24.2. And apex plugin and it works.

I just tried it on my “old” (4.24.1) project, where the bug started, and after upgrading to 4.24.2 it now works! I’m guessing they fixed it.

Found this in the release log of 4.24.2:


**Fixed!** UE-85928 Apex Destructibles are not properly rendered

you cant have ray-tracing enabled disable ray-tracing and it should work. found this out awhile back lol.

https://forums.unrealengine.com/filedata/fetch?filedataid=184395&type=thumb&attachmentnodeid=

I tried actually it is not related that.

You need to disable Support Skin Chace and it can only be done with Ray-tracing off

1 Like

Lifesaver, Thank you.
Have had to ignore Destructible Meshes since 4.24!!! Figured I’d check around online once more and found this. Thank you.

1 Like

Where is “Support Skin Chace”?
Ohhhhh "Support Skin Cache"

1 Like

You guys rock. I was really stuck on this.

So note to self.

Apex will not work with Ray Trace on and Support Skin Cache must be off.