Download

[SOLVED] Destructible Actors not visible during play in one project only, what am I missing?

Hello!

I’ve encountered quite the unexpected issue with the APEX destruction plugin… When spawning, or placing, destructible actors components in any of my maps in my project, upon hitting play or simulate, they all dissapear.

The actors themselves are still visible inside the list of actors present, including the client and server list, but the destructible meshes themselves are fully invisible and have no collision. If I add a static mesh component to one of those invisible actors, the undestructible mesh component itself will render at the right place though, so what’s not working is the destructible component itself, not the destructible actor.

I know that something must be wrong with my project configuration, since I’ve tried using apex on other projects (including other code projects built with the engine source (4.20.1), since that’s what I’m using on my main project) and it works just fine… But I can’t figure out what I’m missing.

Here’s what I have done so far:

  • Enabled the “Apex Destruction” plugin
  • Added “PhysX”, “APEX”, “ApexDestruction” to my build.cs (I’m not using any Apex plugin code in C++ but I figured it might help…)
  • Created a destructible mesh from an existing static mesh, and verified that indeed you can fracture it and all that (in the destructible mesh preview window)
  • Placed the destructible mesh inside the level by drag & droping it directly onto the viewport, thereby creating a destructible actor
  • Also tried creating a blueprint child of destructible actor and placing THAT instead, just in case.
  • Also tried spawning a destructible actor from BPs.
  • I’ve tried enabling physics, disabling physics, setting visible to true on begin play, activate to true on begin play… Nothing works :S
  • I’ve looked at the logs extensively and there’s nothing indicating an error or a warning on the apex plugin side. On the contrary, a few lines about the vertex count and the like are present when it comes to my destructible mesh…

At this point I’m getting pretty stuck, if you have any suggestions, they are very welcome!

And as is usual with that kind of issue, nevermind the fact that I’ve been stuck on this since yesterday, upon posting a question the answer reveals itself within minutes!

So the issue was: In my project settings, the “Max Physics Delta Time” was set to 0.0.