SOLVED: Deploying and Launching to iOS both fail on OSX

Hi all,

UPDATE 3: Yep, that was it. Added some more details in an answer at the bottom.

UPDATE 2: It seems that Apple doesn’t accept arm7 builds any more, so it no point in having anything earlier than a 5S to test on now. Not 100% sure until we get an alternative device, but it seems likely. XCode wins for the most useful install error message, would have been nice if it was more explicit, though. Would have found out much sooner.

UPDATE 1: Pretty sure this is just Unreal isn’t building armv7 support in when I’m packaging, but having trouble figuring out how to enable that on iOS. (or how not to disable it). So if you know the answer to that question, you can likely skip the rest.

Trying this again because the forums decided to fail when I finished writing up this giant explanation of everything I’ve tried on this. Short version is, I’ve done all the steps defined for provisioning, certificates, etc. The bundle ID is also set correctly, and the certificate and provisioning both highlight as green, with the bundle ID being successfully found. Though I do not include the prefix in this, if the prefix is added then the provisioning and certificates are not found and nothing lights up as good to go.

The actual packaging step itself succeeds, but if I try deploy the application, (whether through Launch in Editor, install via iTunes, or install via XCode), it fails.

I’ve got a few leads, but none of them that are enough to provide me any further action items; I’ve read through a tonne of threads, but most boil down to issues in building for iOS from windows or issues with the provisioning, certificates, or bundle id. (Which this may be for all I know, but doesn’t appear to be in the manner any of those have been). Incase it’s relevant, the iOS device in this is a iPhone 5C running iOS 10.3.3 using a MacBook Pro running the latest OS X and UE 4.17.1.

  1. In the log, it complains that it can’t connect to the bundle.

    LogPlayLevel: DeploymentServer: [deploy] Created deployment server.
    LogPlayLevel: DeploymentServer: [DD] Trying to connect to mobile device running iOS …
    LogPlayLevel: DeploymentServer: [DD] Mobile Device ‘Test???s iPhone’ connected
    LogPlayLevel: DeploymentServer: Failed to connect to bundle ‘com.schmutza.Trumpor’ with Unknown error 0xE80000B7

  2. During launch is fails at the application verification step

    LogPlayLevel: DeploymentServer: … Finished copying to ‘PublicStaging/Trumpor.ipa’ in 10.81 s
    LogPlayLevel: DeploymentServer: [DD] Installing IPA on device ‘Test???s iPhone’ …
    LogPlayLevel: DeploymentServer: [DD] … Install is 5% complete at phase ‘CreatingStagingDirectory’
    LogPlayLevel: DeploymentServer: [DD] … Install is 15% complete at phase ‘ExtractingPackage’
    LogPlayLevel: DeploymentServer: [DD] … Install is 20% complete at phase ‘InspectingPackage’
    LogPlayLevel: DeploymentServer: [DD] … Install is 20% complete at phase ‘TakingInstallLock’
    LogPlayLevel: DeploymentServer: [DD] … Install is 30% complete at phase ‘PreflightingApplication’
    LogPlayLevel: DeploymentServer: [DD] … Install is 30% complete at phase ‘InstallingEmbeddedProfile’
    LogPlayLevel: DeploymentServer: [DD] … Install is 40% complete at phase ‘VerifyingApplication’
    LogPlayLevel: DeploymentServer: Install \ Update of “Trumpor.ipa” failed with Unknown error 0xE8000087 in 17.38 seconds

  3. When installing from iTunes, it says that the application is not compatible with the phone.

  4. When installing from XCode, it says the application does not support the device’s type of CPU.

Thanks for any assistance in getting the dev process on Mac smoothed out. This has been amazingly frustrating for a step I expected to be barely more than “press build”.



So that’s confirmed, it’s just deprecated hardware. Working on an arm64 device no problem. So when you see bizarre error messages as above, it could just be your hardware. You can find out what CPUs etc where here

Keep it Unreal - later.