[solved] Crash when I try to build lighting

Hello guys

I’m coming from Unity and try to find my way through UE4 :slight_smile: I’m sure I’m not alone with this problem. Every time I try to build the lighting of my scene, the editor (only the editor, not the OS) crashes. Please see the attached log below (covered in a SPOILER-wrap ^^).

My system is a Macbook Pro (mid 2014), macOS Catalina, i7 2.5GHz quad-core, 16 GB RAM, GeForce GT 750m 2GB and UE 4.24.2.
The scene shouldn’t be the problem as it happens even with the default Scene when starting a game-project (you know, that table and the two chairs). Overheating shouldn’t be the problem either, as the fans don’t even spin up. The SSD has a good amount of free space for virtual ram.

I see in the log something about missing filenames in Metal, but I have macOS on the newest version, as well as xcode.
Has anybody an idea what the problem could be?

Thanks and cheers
Maurus

[SPOILER]LoginId:273ca6f1d542b31b6bc51384c4c84932
EpicAccountId:d1af8c09e5e342a783bc7cb4ca96f695

Caught signal

Unknown() Address = 0x7fff62150cf8 (filename not found) [in libobjc.A.dylib]
-[MTLResourceList releaseAllObjectsAndReset] Address = 0x7fff31244c54 (filename not found) [in Metal]
MTLIOAccelCommandBufferStorageReset Address = 0x7fff31244af5 (filename not found) [in Metal]
MTLIOAccelCommandBufferStorageDealloc Address = 0x7fff31244a71 (filename not found) [in Metal]
-[MTLIOAccelCommandBuffer didCompleteWithStartTime:endTime:error:] Address = 0x7fff31244812 (filename not found) [in Metal]
Unknown() Address = 0x7fff276c0e21 (filename not found) [in GeForceMTLDriver]
-[_MTLCommandQueue commandBufferDidComplete:startTime:completionTime:error:] Address = 0x7fff312446f1 (filename not found) [in Metal]
ioAccelCommandQueueBlockFenceCallback Address = 0x7fff5012547e (filename not found) [in IOAccelerator]
IODispatchCalloutFromCFMessage Address = 0x7fff2ebf2cab (filename not found) [in IOKit]
_IODispatchCalloutWithDispatch Address = 0x7fff2ebf2b2c (filename not found) [in IOKit]
dispatch_mig_server Address = 0x7fff634872f7 (filename not found) [in libdispatch.dylib]
_dispatch_client_callout Address = 0x7fff6347050e (filename not found) [in libdispatch.dylib]
_dispatch_continuation_pop Address = 0x7fff634726c0 (filename not found) [in libdispatch.dylib]
_dispatch_source_invoke Address = 0x7fff634823c4 (filename not found) [in libdispatch.dylib]
_dispatch_lane_serial_drain Address = 0x7fff63475980 (filename not found) [in libdispatch.dylib]
_dispatch_lane_invoke Address = 0x7fff63476452 (filename not found) [in libdispatch.dylib]
_dispatch_workloop_worker_thread Address = 0x7fff6347fa9e (filename not found) [in libdispatch.dylib]
_pthread_wqthread Address = 0x7fff636ca6fc (filename not found) [in libsystem_pthread.dylib]
start_wqthread Address = 0x7fff636c9827 (filename not found) [in libsystem_pthread.dylib][/SPOILER]

That’s odd. I’ve just installed the new macOS update from this week, and suddenly it works. Didn’t do anything else than this, and open xcode and starting a null project, and then closing it again without saving.

Must have been either a corrupted os installation or something with xcode. Seems like you’d have to start xcode first at least once before you can build lighting properly.
¯_(ツ)_/¯

I’m having the exact same problem, but the Xcode thing hasn’t worked for me.
Up dated the OS, fast enough computer etc etc.

This is the error message.

Any ideas, would be really helpful!

Caught signal

DerefFMaskInfo(BronzeTextureFMaskInfoRec const*) Address = 0x7fff2d678ce9 (filename not found) [in AMDMTLBronzeDriver]
amdMtlBronzeSetTextureFMask(BronzeSRDMgrRec*, BronzeMtlTexture*, unsigned int) Address = 0x7fff2d678bdc (filename not found) [in AMDMTLBronzeDriver]
amdMtlBronzeSetComputeTexture(BronzeComputeCmdEncoderMembersRec*, BronzeSRDMgrRec*, id<MTLTexture>, unsigned long) Address = 0x7fff2d64d6de (filename not found) [in AMDMTLBronzeDriver]
FMetalCommandEncoder::SetShaderTexture(mtlpp::FunctionType, FMetalTexture const&, unsigned long, mtlpp::ResourceUsage) Address = 0x1559168b2 (filename not found) [in UE4Editor-MetalRHI.dylib]
FMetalStateCache::CommitResourceTable(EMetalShaderStages, mtlpp::FunctionType, FMetalCommandEncoder&) Address = 0x1559b7ee6 (filename not found) [in UE4Editor-MetalRHI.dylib]
FMetalRenderPass::CommitDispatchResourceTables() Address = 0x1559b8d09 (filename not found) [in UE4Editor-MetalRHI.dylib]
FMetalRenderPass::PrepareToDispatch() Address = 0x1559b1a3c (filename not found) [in UE4Editor-MetalRHI.dylib]
FMetalRenderPass::Dispatch(unsigned int, unsigned int, unsigned int) Address = 0x1559b04ea (filename not found) [in UE4Editor-MetalRHI.dylib]
FMetalRHICommandContext::RHIDispatchComputeShader(unsigned int, unsigned int, unsigned int) Address = 0x15591dc43 (filename not found) [in UE4Editor-MetalRHI.dylib]
FScatterUploadBuilder::UploadTo_Flush(FRHICommandList&, FRWBufferStructured&) Address = 0x1222b5bd1 (filename not found) [in UE4Editor-Renderer.dylib]
UpdateGPUScene(FRHICommandListImmediate&, FScene&) Address = 0x1224259fb (filename not found) [in UE4Editor-Renderer.dylib]
FDeferredShadingSceneRenderer::Render(FRHICommandListImmediate&) Address = 0x122361d43 (filename not found) [in UE4Editor-Renderer.dylib]
CaptureSceneToScratchCubemap(FRHICommandListImmediate&, FSceneRenderer*, ECubeFace, int, bool, bool, FLinearColor const&) Address = 0x12274f8ac (filename not found) [in UE4Editor-Renderer.dylib]
TGraphTask<TEnqueueUniqueRenderCommandType<CaptureSceneIntoScratchCubemap(FScene*, FVector, int, bool, bool, float, bool, bool, FLinearColor const&)::CaptureCommandName, CaptureSceneIntoScratchCubemap(FScene*, FVector, int, bool, bool, float, bool, bool, FLinearColor const&)::$_7> >::ExecuteTask(TArray<FBaseGraphTask*, TSizedDefaultAllocator<32> >&, ENamedThreads::Type) Address = 0x12277301c (filename not found) [in UE4Editor-Renderer.dylib]
FNamedTaskThread::ProcessTasksNamedThread(int, bool) Address = 0x10f09a9a0 (filename not found) [in UE4Editor-Core.dylib]
FNamedTaskThread::ProcessTasksUntilQuit(int) Address = 0x10f099813 (filename not found) [in UE4Editor-Core.dylib]
RenderingThreadMain(FEvent*) Address = 0x116a18e13 (filename not found) [in UE4Editor-RenderCore.dylib]
FRenderingThread::Run() Address = 0x116a88ef7 (filename not found) [in UE4Editor-RenderCore.dylib]
FRunnableThreadPThread::Run() Address = 0x10f156fd6 (filename not found) [in UE4Editor-Core.dylib]
FRunnableThreadPThread::_ThreadProc(void*) Address = 0x10f10aeb1 (filename not found) [in UE4Editor-Core.dylib]
_pthread_start Address = 0x7fff706e0e65 (filename not found) [in libsystem_pthread.dylib]
thread_start Address = 0x7fff706dc83b (filename not found) [in libsystem_pthread.dylib]

Must be loads of people with the same problem, anyone found a work-around?