[Solved] "Connection to the server failed" Tied everything, no fix yet

Been getting this message at log in every time. I’ve tried everything mentioned on this page but nothing seemed to work.

Debug Logs

Appreciate any suggestions.

EDIT: Solved. Adding “http=wininet” to end of target line of Unreal Launcher desktop shortcut solved issue.

Hello sleazefrenzy,

I’m sorry to hear you are having trouble. Please try adding -http=wininet to the shortcut target line. In addition, please try adding the following as an exception on your firewall:

xmpp-service-prod.ol.epicgames.com port 5222

If this does not work, please reply back and we will continue to look into the issue for you.

Thanks for the reply. I have tried the target line before to no avail. I added xmpp-service-prod.ol.epicgames.com to the whitelist in Bitdefender which didn’t work. I’ve turned Bitdefender off completely (and Windows firewall/defender are off by default) and still get the same error.

Hello again!

Based on your logs, I do not see the “-http=wininet” switch in your target line. Could you please add that back to the shortcut and generate a new set of logs for us?

Solved it! I was putting the text in the target for the Unreal Editor rather than the Launcher shortcut…

Thanks for your help.

Please put how you solved it in an answer and mark it resolved. So, other people can locate your hard work. !