[Solved]Close gate works if I wait a few seconds?


I have two HUD blueprints setup and gates to control location following on characters once I click on them and their HUD is up. On clicking a close button in either HUD I close the respective gate stopping the follow. It works instantly with my NPC HUD when clicking on them or closing the HUD.

For this new player character (recently setup) I have to wait a few seconds before clicking that close button or the pawn sphere gets stuck following him. I tried putting another check for close button (on_clicked) event with slight delay and the delay seemingly gets doubled even at .002

I’ve setup two controllers and was thinking the second one might be what is causing the issue. I don’t really understand why though because I’ve set it up right and it works. Sometimes its instant most of the time you have to wait like 6 seconds.

Second controller is just one simple cast to first controller for Ref then it bind two events from the dispatchers in the first controller (LMB Pressed/Released) for a gate to allow the location to pass towards a simple move to node.

The yellow boxed nodes are the two which are giving me issues. Now that i’m thinking about it the Booleans there will get set to false because I regain my desired cam controls but the close follow part just never gets there.

Even this gate here in the additional player controller fires on point no issues with my LMB event dispatchers.

I can watch this on debug delay the open a bit after I click on player (though it will still follow instantly)

The solution came to present itself while writing this. It was due to a timeline length of 5.00 rather than .5
concerning a pre-lerp to location where it wouldn’t finish for 5 seconds. The pre-lerp still follows but is meant to only get to the location where another lerp will do the following. Since it was set too long it was acting as if the second follow was working while it was actually the pre-lerp lasting for 5 seconds, finishing and then opening my desired gate.

This was seemingly affecting the close button because it closes the gate but it can’t, if the gate doesn’t get opened until 5 seconds later. XD

Continuing the posting to assist in understanding. Perhaps it may help someone as well.