[Solved] Can't find some blueprint dependencies

So, my situation is that I have what should be a fairly small BP with minimal dependencies - but if I try to migrate it it wants to bring along my player character and half my project.

I can see in the “Reference viewer” it mentions my character BP (and another It should not depend on) - also, if I open the BP in a text editor, I see a matching string.

But I can’t find any mention of the reference inside UE4.

What I have tried:
-Find in BP
-Find in all BP
-manually checking:
–function in/outs

I’m about at my wits end - remaning options I can think of are:
-heck to it.
-dig into UE4 source, find the BP loading section, and perhaps get it to spit out a plain-text version or otherwise let me know what this “phantom dependancy” is

Hopefully one of you can suggest a better method? Am I missing something obvious?

Nevermind, fixed it!

Just kidding, so of my two mysterious deps…
One was an old “reroute node” attached to a “get actor location” - removing this fixed it.
Second was an old reference to a blueprint of its own type.

So both really were errors on my part - still, would be nice to have better tools to handle this kind of mistake in the future