Solved : Cant Enable RayTracing in UE5 (gtx 1060)(Nvidia Pascal)

that was my fault
its Working

repalce this file in
UE_5.0\Engine\Binaries\Win64

also add
ConsoleVariables.ini
r.D3D12.DXR.AllowEmulatedRayTracing=1

2 Likes

I created a pull request.
https://github.com/EpicGames/UnrealEngine/pull/9214

Let’s hope.

3 Likes

I did all, compelling that took ages, I end at 2AM.
Replace the file in UE_5.0\Engine\Binaries\Win64
I put “r.D3D12.DXR.AllowEmulatedRayTracing=1” into the Engine ConsoleVariables.ini

I guess I miss something but I did all that you guys said but did not work for me. I have a GTX1080Ti.

I hope Epic make a move and brings it back, this is frustrating.

Thanks guys for sharing!

1 Like

Not sure where you added the command.
ConsoleVariables.ini is in “UE_5.0\Engine\Config” , just paste the command on the end of the .ini file.

Mate thanks so much for pointing this out, I can’t believe it, is back, Ray FLIPINGTRACING!!!

Thanks again evilboys!!

My bad, I thought it has to be inside Unreal.

1 Like

Of course, hotfix 5.0.2 resets the DLL and the .ini file. Pretty sure the old DLL will work just fine but in case someone is compiling it, that’d be welcome.

2 Likes

hi @JohnD @evilboys @Farshid
I have made a repository which may help you see post

Luoshuang’s GPULightmass - UE 5.0.3

Works fine out of the box on a 1080TI, no need to compile any custom builds.
Just tick Support Hardware raytracing then restart.
Once you restart the other setting (Use Hardware Raytracing when available) is now accessible.

1 Like

Hi all,

When emulated ray tracing was available, a very significant amount of the crashes related to ray tracing we got through our Crash Reporter tool were happening in the 10x series cards. These crashes where happening mostly on the driver side or in TDR timeouts that were not actionable in our side. That means a lot of engineering and QA time spent on a path that is not future looking, so we decided to disable it leaving the code for users who might want to enable it at they own risk. Enabling that again will mean that time we need to invest in improving this technology will be spent on fixing and workarounding things on a code path that is not future looking.

Nvidia just updated the info of their RTX plugin specifying that a DXR capable GPU is needed for using that plugin, DXR emulation is not officially supported there anymore.

Best,

   Juan

So annoying. I hope there will be another compiled DLL, the old one didn’t work for me on 5.0.2.

1 Like

Wouldn’t it be better to warn users about this before they’re turning on raytracing on GTX GPUs? Is the solution really to DISABLE the whole raytracing part, along with path-tracing rendering? Extremely disappointing. I’ll stick to UE4 for now then.

1 Like

That’s very understandable (working on something that is not going towards future tech).

However you could keep the command line compiled in code and have it by default disabled, and us users who know about the risks and still need that feature on some projects can just write that line of command inside the ini file and have it activated (until nvidia decides to remove it fully from future drivers).

I hope you could consider that option instead of having always to try and compile a new custom engine or DLL on each new unreal version.

Thank you!

P.S: If someone has the 5.0.2 DLL compiled and could share, we GTX users would really appreciate it :slight_smile:

2 Likes

Hi @ydem

There is a link to the new 5.0.2 in the post
Luoshuang’s GPULightmass 5.0.2 by pax_invictus

Hey @Jimbohalo10,

I see that this is the GPU Lightmass, I’m using lumen and dynamic light, and can’t see the D3D12RHI DLL in there.

Do those recompiled DLLs allow this command line to execute? : D3D12.DXR.AllowEmulatedRayTracing = 1

Hi @ydem
Here is my output log for the command carried out as a console command.

LogShaderCompilers: Display: ================================================
Cmd: r.AllowStaticLighting
r.AllowStaticLighting = “1” LastSetBy: ProjectSetting

To prove command working induced error

Cmd: r.AllowStaticLighting =1
Warning: Processing the console input parameters the leading ‘=’ is ignored
(only needed for ini files).
Error: r.AllowStaticLighting is read only!

from $ notepad Config/DefaultEngine.ini

[/Script/Engine.RendererSettings]
; exposure control and tone mapping settings
r.Tonemapper.Sharpen=2
r.DefaultFeature.AutoExposure.ExtendDefaultLuminanceRange=True
r.DefaultFeature.Bloom=False
r.DefaultFeature.AutoExposure=False
r.DefaultFeature.MotionBlur=False
r.SceneRenderTargetResizeMethod=2
;add render emulator
r.D3D12.DXR.AllowEmulatedRayTracing = 1

Here is my Project settings

Thanks, seems like the raytracing only worked after I added the DLL from the earlier post in here : Solved : Cant Enable RayTracing in UE5 (gtx 1060)(Nvidia Pascal) - #44 by Farshid

Now I have also path tracing working! Thank you all for sharing the files.

1 Like