[SOLVED] Build/compiling has no effect (wrong binaries)

I was doing C++ tutorials from official documentation website, and after finishing my project i did in VS “Project-only > Build” (it was, like 3rd building in currect session, other 2 were done with not fully finished code), when build compleed i alt-tabbed to Unreal Editor and began playing it, but i noticed, that my latest compiled changes were not working (an outdated version worked), then tried “Compile” button from Editor - still no effect.

Although a found a workaround, i want to know how to fix/disable it, or why it is happenig.

The problem was, that in “my project folder\Binaries\Win64” the are DLL and PDB files, but with different versions:


Screenshot was created after fixing, i posted it just to demonstrate, that VS and Unreal Editor (both) generate newer files with longer filenames, while Unreal Editor is Play-testing an original filenames, which were outdated.

The play-testing was updated, when i renamed latest DLL and PDB pair of files to default name (the 23:39 ones), so why those “back-ups” (or they are not back-ups) were created and why Editor did not run latest version, or how can i disable VS creating them, how can i avoid it in the future?

for example, DLL and PDB with “-1789” are newer, but Unreal Editor is running the 23:39 version, rather than the 23:44 “-1789” version

looks like it was just a bug, on another tutorial project Unreal Editor uses those fresh files with longer names. (this time those DLL files (all versions of them) were all locked by UE process)

the bug may or may not be related to “delayimp.lib” bug. As it sometimes pops when compiling from Unreal Editor (even with added “$(LibraryPath)”, completely closing both VS and UE, and the running UE helps here. Have not tried 4.11 preview yet, heard it has some of those bugs fixed