[SOLVED] Bug 12270: Did memory consumtion of orthophoto calculations increase with latest version

Hi there,

Since the update to the latest version RC I cannot do ortho projections with the pixel count I was used to before anymore with my 64 gigs of RAM. The calculation eats up all the RAM and then fails. I can understand that I might have not enough physical RAM, but calculations that worked with the old versions, fail now, if I try to redo them. Any hints on making my orthophotos work again?

My system specs are:


This dataset fails

This is the log file that was generated

RealityCapture RC (c) Capturing Reality s.r.o.
Using 12 CPU cores
Added 286 images
Loading Project completed in 7.906 seconds
Orthographic Projection Calculation in Progress failed after 248.861 seconds
Processing failed: Operation failed
Orthographic Projections Calculation in Progress failed after 248.876 seconds

Here’s the task manager during the calculation:


This dataset could be rendered on the same machine without problems with the old version.

It now fails with this log file:

RealityCapture RC (c) Capturing Reality s.r.o.
Using 12 CPU cores
Added 317 images
Loading Project completed in 41.454 seconds
Processing failed: Operation failed
Orthographic Projection Calculation in Progress failed after 212.073 seconds

Any hints or help is highly appretiated.

As a side node, the calculations fail on a Dual-Xeon machine, too, that has approx. 80 Gigs of RAM.

Best mnu

Hello Achim,

thank you for letting us know. The thing you are pointing at has not changed so there must be a different issue. We will need to investigate it closer. However, it may take more time so please excuse our possible later answer.

Thanx for the info lubenko. Is there a possiblility of using the old version in the meantime to get my stuff out?


Hello Achim,

would it be possible to share the project file and project folder with us, only with the one model that is textured and that is causing problems so that we can test it on our side?

You mentioned that you were able to create an ortho projection in the same project in the previous version. Have you tried to create an ortho projection from the same singleton model with the same number of textures?

I believe that the issue with this particular model is same as mentioned here:

You have one singleton model with over hundred textures and RC is loading all the textures when creating ortho projection at once. That is the reason of the large memory consumption.

In the meantime, you can try the workaround proposed also in the thread mentioned above:

  • Import the model and change in the RECONSTRUCTION - Settings - Model import the ‘Maximal vertices count per part’ to a smaller number so that model will be divided into parts and unwrap and texture the model again. Or if the model was created by simplification, change Preserve parts to ‘True’ in the Simplify tool settings and again unwrap and texture.

You should be able to create an ortho projection without problems. 



Hi Zuzana,

thank you so much for your help. I understand what you are telling me. It’s just that I was wondering as the exact same projection of the exact same singleton model on the same computer worked before. And not only on this dataset. I have more than 10 datasets where this is the case. I’m happy to share the dataset with you. It’s just that this is really big. 16bit tif files. The images alone is 90 GB. So how could I possibly share this with you? Any ideas. 

In the meantime I’ll carefully go through the thread you mentioned and try what you suggested!


Hello Achim,

thank you for reporting back, we will test it on the previous version as well.

There is no need to send the images, we need just project file and project folder (make a copy of the project and keep only the one textured model). Would it be possible to upload these files for example on dropbox or google drive and share the link with us? Thank you. 

Hi Zuzana,

i’ll try to send it via wetransfer later today. Do you have an email address that I can use?  I’ll get back to you as soon as I have something online. Thanx again!

You can send it via the contact form on our webpage (https://www.capturingreality.com/Contact#Contact). Thank you. 

I managed to upload a zipped version to google drive. Here’s the download link:



Hello Achim,

thank you very much for sharing the data with us. We will take a look at it and get back to you. 


Same problem here :frowning:


Project with 6.6k inputs. I need to export about 60 orthoprojection. Random error during orthoprojection calculation. I have 128gb of ram. Ortho projection with 16500x6700 resolution consumes 110gb of ram. After the calculation is done, ram drops only to 80gb. So, there is obvious problem with RC not clearing the ram?


Didn’t have this problem with earlier build. Tried to clean temp and reseted the RC to factory default with no luck.

Hello Vektra,

can you please try the workaround proposed here?

Thanks :slight_smile: