Download

[SOLVED] Blender animation is imported with INSANE amount of keyframes

I’ve run into this peculiar issue this morning and I can’t quite understand what’s going on

I am animating a simple swing in Blender. Upon exporting it to the UE4 Mannequin, the animation itself is perfectly fine, but the amount of keyframes has gone from the 60~ I have been working with to around 2000 (!)

I’ve tried opening up the test FBX file I have exported in 3DS Max. The amount of keyframes is fine.

Blender rendering/playback settings:

Here are my export settings :

My import settings :

Forcing an animated range of 60 frames cuts down the animation

Thanks in advance for your help!

UPDATE : Checking “Use Default Sample Rate” seems to be a working fix