Download

SOLVED: Ark DevKit - Persistent buff updating character max stats dynamically

Long story short, I’m currently in the process of creating an ice-themed map for Ark.

One of the main features of the map is a persistent buff based on the Heatstroke (Scroched Earth), which I called Frostbite.
Essentially, it is supposed to :

  • Update its icon according to the current Frostbite amount. (Working as intended)
  • Add an ice overlay on the UI with its visibility based on the Frostbite amount. (Working as intended)
  • Dynamically change the max weight/speed/melee damage of the player by a percentage, calculated from the Frostbite amount. (Need help on that one…)

The calculation used for all three stats affected is the same :


I aimed to have the player progressively & temporarily lose up to 20% of his weight/speed/melee stats.

Attempt #1
After hours of research and messing around the dev kit, I came up with the following function to change the Max Stats Scaler properties.

Of course, I did set default Max Stats Scaler in the appropriate non-graph section of the BP. I also integrated a call to the “Max Stats Scaler” function in the “Buff Tick Client”. This first approach worked perfectly when testing within the dev kit itself, but also in singleplayer (SP) as well as non-dedicated sessions. However, it failed when playing on an actual server.

It is to be noted that I also tried to move the call from “Buff Tick Client” to “Buff Tick Server” instead with the same results.

Attempt #2
I ditched the max stats scalers and went for a “Rescale Max Stat”. End result looks like :


Exactly like my first approach, everything did its job within the dev kit, SP & non-dedi. It still won’t work on a server.
Again tried to move the call from “Buff Tick Client” to “Buff Tick Server” with no changes in the outcome.

Questions
1- Is what I’m trying to achieve possible in the first place? I mean to properly work on a live server…
2- Is there a way to configure the dev kit environnement to a server-like status? Cooking during 4 hours for a few mins of testing on a server is highly frustrating…

I’m sure it’s just a little checkbox or detail somewhere, but thanks ahead for anyone helping out.


For anyone reading and/or facing a similar issue.

1- Unchecking “Local Percent” on the “Get Stroke Percent” did the trick. I had to use method #2 within the “Buff Tick Server”, but it works flawlessly in SP/non-dedi AND servers finally.
2- Check the “Run Dedicated Server” option in your play settings.