Download

[Solved] 4.25 RunUAT.bat BuildPlugin incorrectly tries to build for Linux and other platforms

Hello

I try to build a plugin with the same command line I used since 4.19


RunUAT.bat BuildPlugin -Plugin="C:\Users\...\XXX.uplugin" -Package="C:\Users\...\XXX" -Rocket

it worked until 4.24 but with 4.25 it fails and the error is like that:



Building plugin for target platforms: TVOS, Android, HoloLens, IOS, Linux, LinuxAArch64, Lumin, Win64, Win32
Running: C:\Program Files\Epic Games\UE_4.25\Engine\Binaries\DotNET\UnrealBuildTool.exe UE4Game Linux Development -Project="C:\Users\...\XXX\HostProject\HostProject.uproject" -

.....

ERROR: Platform Linux is not a valid platform to build. Check that the SDK is installed properly.


I have no linux or other platforms in the whitelist file, only windows.

Is there any other places those platforms can be specified as targets?

Problem is solved by adding target platforms to the RunUAT BuildPlugin command, like that:


-TargetPlatforms=Win32+Win64

Still strange that it worked without until 4.24, is this something that was introduced in 4.25?

Just wanted to say cheers for posting the solution :slight_smile: