Download

[Solved] 4.24.1 seems to crash importing very basic skeletal FBX (from Blender)

UPDATE - FIX ]

Ensure the FBX skeletal mesh has a Material (in Blender). Many thanks to Yaroslav for his answer below.

[UPDATE - This is a bug. ]
https://answers.unrealengine.com/que…1760/view.html ]

I’ve never had any issue importing rigged meshes from Blender to Unreal before. In fact, it’s always been a breeze.

However, since I upgraded to the latest version, I’m getting a crash as soon as I click the import button to confirm import settings.

For instance, I created a simple cylinder mesh with, say, 4 linked bones in it so it moves like a bendy-straw. I’ve reduced the complexity of objects again and again but it seems to be something in this latest version that causes this crash regardless of the mesh or how many bones or even how those bones are linked.

To be sure, I re-installed an older version of Unreal (4.16.3) and all the files import fine!

Here is the error I get with the recent version:




Assertion failed: (Index >= 0) & (Index < ArrayNum) [File:D:\Build\++UE4\Sync\Engine\Source\Runtime\Core\Public\Containers/Array.h] [Line: 614] Array index out of bounds: 0 from an array of size 0




Did you try deleting 4.24.1 and reinstalling clean? I’ve had strange update behaviours in the past with version updates.Clean installs usually fixes it.

Hi Frankie, yeah it’s definitely a bug as other people are now reporting the same thing (via the link I added to the original post).

I did re-install again today just to be sure but the assertion error leads me to believe something has changed in the way the MeshBuilder is reading the data.

I filled out the bug report, but when you click “submit” it doesn’t take you to a confirmation page. I suspect they may receive about 8 of the same report from me… :o

Hello, I took a look at the the skeletal box in the link you provided from AsnwerHub. Yep, it crashed, it looked like a problem I encounter couple of weeks ago. Basically, regardless of whether you choose to create or not create material in Unreal’s FBX Importer** it will crash if you don’t add material in Blender before exporting skeletal mesh.** So if your model doesn’t have a material, simply open your model in Blender, add a material, and export it. Then Unreal’s importer shouldn’t have the problem. If you have material added/applied to mesh already, but yet it still crashes, then, I’m afraid it some sort of other issue.

Funny, as far as I remember, before Unreal could easily import model whether it is skeletal or static mesh without material, but now only static models can be imported w/o material applied beforehand. For skeletal meshes, you need to manually add them materials in blender.

Hi Yaroslav, that’s it! Thank you!

This all started when I wanted to test an alternative to using Unreal’s Cloth simulation. So I created a plane, added some bones, exported and found that it was crashing.

Looks like I forgot to add a default Material :o. So every test object I exported from then on, I forgot to add the Material.

Would you mind copy and pasting your post as an answer on the Bug Report post I linked above? (that way you rightly get the credit for solving it :slight_smile: )

Thank you so much! Was about to throw either myself or the computer out the window

it’s 2020 and with blender 2.8 and unreal 4.24 this problem is still a thing.
thankfully the same fix of adding material in blender is working too, so thank you so much!

How are you going to ever use a mesh in engine without a material? You won’t.
There is literally no reason to fix this. Every mesh NEEDS a material assigned for proper usage - and that’s likely why it’s still a thing in 2020.

The fact that it crashes is obviously a regression from 4.23, where it imported the model with a warning. Having something like this crash with an unhelpful error message is bad UX.

The primary reason I could see someone wanting to use a mesh without a material is for greyboxing while they’re working on the model. For example, if they’re working on a level that’s going to have statues in it but they want to just get a quick idea of how they might approach placement prior to the model being done.

4.24 has tons of issues. Crashing on import is most definitely a regression, if it were true.
Instead, counter to things otherwise state in this topic, the mesh imports fine, and a material slot is assigned to it - named “WorldGridMaterial”. So the issue itself had obviously been addressed.

As far as your reasoning behind why one would not assign the material in the model - it makes little to no sense.
usually you want to pre-color the thing you are previewing and maybe even texture it with a color table to see if your UVs are OK or not… in fact, if more people did that we’d probably see 15% or so less “this doesnt work” posts…

…if it were true? Seriously? There are multiple people corroborating the same behavior here. I experienced it myself on 4.24.1 a few days ago. One of the links provided by OP in an update has a reproducible test case. I just tried it and, sure enough, importing it crashes 4.24.1 on Windows.

And just because something doesn’t make sense to you doesn’t mean it’s not a part of someone else’s workflow.

Create a cube in blender, add a bone to it. Parent the 2, and import it. Works just fine, and gets a default material assigned.

I also found that adding a material in blender to the skeletal mesh avoided the crashes. Static meshes imported OK without materials assigned. Thanks Yaroslav

I nearly lost my mind on this one, it was definitely a bug with having no materials! Good catch!

My mesh has materials. I had similar bug when I was trying to reimport my skeletal mesh in 4.24.3. I tried many things, but it finally worked when I removed physics asset and “reimported the mesh with new file” (I selected the same file, by the way). I don’t know which one worked, I did those two things at the same time.