Solidworks assembly to unreal 5 import issue

Hi there,

Any tips on importing solidworks assembly files into unreal 5?

If I import an assembly directly into my scene, the product is not visible, only the actor.

If I install the solidworks extension and save as the assembly using the data Smith extension, and then import the assembly: it is visible but without any materials or decals and often elements are missing.

Please I hope someone has some suggestions.



Hello Tim can you give more details:

  • which version of UE5 are you using? Early Access or you rebuild from source from github?
  • do you have any error messages when you import the SLDASM? Sorry to ask but you did not forget to have the corresponding part files next to the assembly?
  • did you already try on 4.26 or 4.27?

Could you share the file with us so we take a look?

Hi there,

I am so sorry for the late response. Thank you for responding by the way I didnt expect anyone to respond.

So to answer your points:

  1. I am using Early access - Unreal is completely new to me and I intend on using it for Product visualizations and Augmented reality / Virtual showcases.

  2. I don’t get any error messages. I was importing only the assembly first time round, so thought perhaps it must be showing up as an empty actor (if thats the correct term) because it cannot reference the parts. So i tried again but imported all the parts too. Same thing. Thing i just tried with a parts file and also it is empty.

  3. I havent tried on older versions but perhaps i should download it and try that next.

I have added a WETRANSFER link below for you which contains the assembly I was using:

Basically I used the template found under Architecture which is on the desert type island with the very retro looking white structure that allows you to play with the suns position etc.

Thank you very much for your assistance.


Seems like it is failing on 4.26. I am trying to figure out why. I did not test Early Access but code is very similar to 4.26 for Datasmith so not surprising it is not working.

It works on 4.27 and the current UE5-Main. So you should try on 4.27 for now on.
Only the “larson counter top assembly.SLDASM” does not load, but it also do not load properly in solidworks so I am assuming something is really wrong with the file.

When you load an assembly, you only select the assembly file in the datasmith file selection windowd. The importer will look for the associated parts automatically.

Import in UE5-Main, of “WALL MOUNTED ASSEMBLY”:

What i have found is that dempending on which version of SolidWorks you are using can cause issues for import. I have Solidworks Maker 2022 and it won’t import at all, SW2018 SP5 no problem, as for SW2019, 2020, 2021 not sure but they may work. I think that the 2022 version is still being worked on. the way i get around this is convert to A step file then import into Unreal 5.12 no problem. one of my assemblies is 315 meg in size and Unreal 5 imports the step file just fine.