Sockets are huge and scale things

I made all my models in blender, and while everything scales nicely in the game world, if I attach anything to a socket on a skeleton, it just gets rescaled to an immense size. I tried messing around with unit scale in Blender, and the size at which it is exported affects this, however, seems to depend on the actual size of the bones or the model, rather than the unit scale it is exported at, because even if I decrease the unit scale, but scale up the model afterwards, the bad scaling continues to happen.
It also affects anything attached to the actual models, like a anim notif particle effect.
Is there a setting I’m missing that could solve this issue ?
The sockets were all added in unreal, and it happens on any model that I’ve made.

Hey, kinda late here, but I’ll answer this anyways in case someone (or me in near future) stumbles upon it.

What worked for me in Blender 2.8 is setting the Units to Metric 1.0 but making sure the root object, in my case it was the armature, had actually a scale of 0.01. You can achieve this by scaling it up by 100, applying the scale (Object > Apply > Scale) and scaling it back to 0.01.

I found this by importing meshes I previously exported from UE4.

It’s kinda messy but it worked for me and messing around with unit scales just made it worse… or it made working in Blender worse as you had to scale everything by 100 and work on that, which kind of breaks all the render distances etc…

Hope this helps someone! Cheers

This video helped a lot to resolve my issues.