Download

So yeah, my project got corrupted :(

I have no idea what’s wrong.

My main level map and my main menu both crash the engine. I can’t even right click on them, hell, I can’t even delete them from the content browser, it crashes. I even restored 3 month old versions of them, still no go. I don’t think it’s an asset fault. Worst thing is there is no error report. It just, disappears. Neither 4.10 nor 4.11 can open these assets. On the other hand these exact same assets work if by themselves in a brand new project. I can only assume something went wrong with the engine. During downloading the 4.11 version I had several Code 0 errors and even had to restart my computer to get the installation going.

Unfortunately in my attempts to get the thing running again I converted all my 4.10 backups to 4.11, so I don’t have an example for the previous versions, but you’ll have to take my word for it that the projects always failed to open the main level. I avoided total asset loss by some miracle, but it is strange that even after verifying the engine install, any and all backups (including the in-project backups/autosaves) failed to load.

Granted this was a goofing around project. I was trying to make the worst, most boring and punishing game in the world. I was 95% done…now half the work is gone. Anyone have this happen to them as well? If so, how did you fix the problem? I’m thinking of getting some local backup software since I’m getting tired of copy/pasting projects manually into another folder. I don’t have the connection speed to run perforce, but I’ll gladly use it if it works as a local version control tool.

Just figured I’d let you guys know. I ended up making a brand new project and importing all the assets, since deleting the Confing/Intermediate folders in the original project didn’t help at all. Also, I had to name my new project differently, since using the exact same name also resulted in a failure.

Sounds bad.
Have you tried this? Google
Good luck
me making backup now
:slight_smile:

Yup, googled a lot myself. I’m restitching the BP’s atm, but man, this sucked.

This happens to everyone. It’s an important lesson that we all have to learn so that we back things up. Perforce, Git, whatever. Wet all need to back up our projects. :frowning:

That’s what I’m saying, it wasn’t a corruption in the asset, they work fine in a brand new project. I literally imported the whole content folder and I had no errors aside from some broke refs. Does perforce support a local backup? Do you recommend using it? Over some of the default file backup tools?

I’ve not used Perforce, only Git, (specifically BitBucket, who do free, private repos) but my preferred method is an external hard drive. Also, I don’t delete older project versions, for a while, until I’m happy with the new version. This is a lesson learned from experience. :slight_smile:

Good luck with getting it sorted. It sounds like you’ve got enough to get you back to where you were.

Same here ^^
I also clone my working directory for all stuff i made (models 3D/2D stuff anything) to an external drive and never overwrite it.
Now i need for every backup 18GB (project + all assets).
Had a corruption once and reacted in panic and made everything worst.
Much space needed, but one time ago those old files helped me to reconstruct a project, without older files it would be end of the road.
Sure most clones are useless, because assets/files not changed, but i a m really scared about lost of stuff again.

I do not trust that online stuff.
:slight_smile:

Verify the backups

Recommend verifying backups. I lost some work this week due to a corrupted save. (start of umap level file is blank)
Not much gone, but when you’re iterating sometimes serendipitous level changes are gone for good because you can’t them back…

There are many posts advising to look in saved / backup, and copy files back to the content folder and open from there
I had a several level files (*.umap) to choose from, tried all, but no joy, not one opened. These saves never worked in UDK either!

Just a guess, but maybe these save files contain incremental changes and only work if autosave is enabled or something like that.
Either way, take it as a warning and test crucial backups especially level files (*.umap) when copying to external drives / Cloud.

Form the same lesson learned in the past.

I had more or less the same problem in a 4.09 project, I believe, and of course I did not make a back up. To save the work done I created a blank project and from the host crashing project I moved each of the content files over one at a time until the project would crash. In my case I got lucky and it turned out to be a single malformed image that I replaced from storage.

So eerm…I don’t know how to put this, but after painstakingly restitching the fragments of my project, getting to finally compile I realized something that ****** me off once I confirmed it…

So here it is: I initially thought that my main level map was corrupted (after all, attempting to load it was crashing the engine with no error report). After failing several backups, autosaves and restores from both in-engine and manual redundancy files, I realized that I’d have to make a new project and migrate as much usable stuff as I could. Now of course a lot of things were broken, like a game mode variable defaulting to a simple “Object” type, and all the subsequent casts transformed into “Bad Cast Node” and apart from a few lost configs, I was pretty well off.

It wasn’t until after fixing the main menu, that I saw this: c2bf17ed139e915b9937c3f47052de8ba54a697f.png

This button was a child widget of the MainMenu class, so I thought during the migration something got broken. I tried to open it to restore the dependency and got this: a4137121e8.jpg

Then I thought to myself “Well DUH, if it can’t find the parent how do you expect to access it” and then it hit me…it wasn’t the main level map that was broken, in fact, nothing was corrupted at all, I was restoring the wrong **** thing. Whaddaya know, I restore the widget and boom everything works again…

What’s confusing is that I had no warnings, errors, or any problems when I made this button widget a child of the main menu. I did this because I wanted to play an animation when the mouse hovered. And since buttons have no OnHover event, I ended up making a separate BP and use the OnMouseEnter/Leave events to fire off the animation. The only thing is, that I couldn’t connect the made button with the main menu, somehow the game mode wasn’t popping up in the asset search. 07eeddd77465b47c2472c9a0b107639a3c7682f2.jpeg

Anyway, after trying several ways to send the execution from the button BPto the main menu, I decided to just make the button widget bp to inherit from Main Menu. It worked out but somehow the animations didn’t fire. At any rate, after this the engine wouldn’t load neither the main map or the main menu, and the rest you know.

So, if I had a version control tool, this would’ve been easily fixed. Now I have a local Perforce depot, and man, do I feel good. I’m still a bit bummed out about the WHY and WHAT exactly broke when I made that button a child, but it doesn’t really matter. Lesson learned. Now I gotta figure out how to make this **** button fire off animations on the main menu,let’s just hope my next brilliant idea won’t result in the same catastrophe. At the very least I came out with a source control setup, so that’s something. Thanks for your help guys :slight_smile:

Yeah I had some pretty terrifying project corruptions followed by marathon manual blueprint reconstruction before I finally got into perforce. While initially figuring out how to set up perforce is way more complicated than it should be, once you have it running you can pretty much recover from anything.

It can’t be overstated how important perforce, git, etc are when you are talking about the validity of months and years of work.

This is something that rarely happens, but it hurts when it does so.

If my computer get a crash while I am working on a blueprint, such as a BSOD, it gets corrupted. It becomes beyond repair and unreal just can’t see it despite the fact that the file still being there. Ofcouse backups and autosaves are there to save the day! :stuck_out_tongue:

Anyhow, I am happy to see you have solved it. :slight_smile:

Sadly there is no way to actually see the blueprint data, it’s enclosed in a magical box. Sometimes something inside breaks, and since it’s a box, very often it’s unfixable.

I’ve been trying to reproduce this in a blank project, but I can’t get it to break. So I don’t know if it’s a bug in the engine, or I’m retarded and did something so stupid the project couldn’t take it. Either way, just be careful guys, I know I will be.