Download

Snapping rotation issues?

Hi everyone, I’m modelling a spherical modular environment. In 3ds max all the planes of the sphere fit perfectly (with the pivot point still in the center of the original sphere) with a rotation of 22,5 degrees.
Picture (Max) Screenshot - a931ad95f0ea1bc9d32242b72a93b81e - Gyazo
When I import thoses meshes to Unreal, and I use the rotation 22.5 snapping (that should give me the same result as in Max) the pieces arent fit togeter, there’s a gap between them.
Picture (Unreal) Screenshot - a1a0b7ee1d4af00f351a783cd9098e0a - Gyazo
The pivot point hasn’t changed, the FBX is correct. What can I do to fix this so it works the way i want?

If you exporting 1 segment of sphere, you should check if they pivot in 3ds max are put in 0.0.0 othervice pivot in UE will be different.
This happining cause when you exporting your model in FXB pivot center of model will be forced to 0.0.0
So if you model are can be duplicated with 22.5deg. nicely around they pivot point, in max, you should check if they also placed in 0.0.0 (not only in “affect pivot only” mode!)

Thats a simple example. My sphere also 16 segments. Pivot are 0.0.0 in max. No seams or gaps in UE.

Oh looks like UE have nice feature for that :slight_smile: Then you importing your model check that option in the “Mesh” settings of import window- “Bake pivot in vertex”. So where no problem if you model not in 0.0.0 in max :slight_smile:

It worked, thank you so much, both of you, Guys!