Snapping in Sequencer broken in High DPI mode


I just wanted to bring to your attention an issue which occurs in 4.14.2 using the HighDPI aware flag. In sequencer, the snapping from one shot to the next does not behave normally, resulting in the shots appearing to significantly overlap. In the non-high dpi version, everything behaves fine.

It would be great to see this issue addressed in an upcoming fix, as I find myself using only the High DPI version of UE4 continuously due to its much more usable appearance on my 1440p monitor.

Thanks so much for looking in this!


Hey AJ_Graphix,

Just to be clear, you’re referring the “-enablehighdpi” command argument?

I’m having trouble reproducing this on my end. Can you reproduce this in a blank example project and send it to me?

Hi ,

Thanks so much for your reply. Yes, this is with the “-enablehighdpi” command argument. I haven’t tried this in a blank project, because I discovered this while attempting to follow the [Cinematics with Sequencer][1] tutorial series, which was using the Infinity Blade Firelands assets along with the Infinity Blade FX and Adversaries.

You can see in the attached photos below the difference between HighDPI ON and OFF. The clips have not been moved on the timeline at all between the two different screen captures.



Thank you for looking into this.

Have a good evening!


I should mention I’m at 125% scaling in Windows 8.1 64 bit. However, I just tried it at 200% and it’s even worse, causing Shot_01 to appear to stretch from 0 - 500 frames. :slight_smile:


Hey AJ_Graphix,

UI Scaling was what finally got the repro. I’m on Win7, which doesn’t have UI Scaling, so I tested on Win10 and was able to repro. I’ve entered UE-41680. Thanks for reporting this.

You’re welcome; thanks for checking on that and entering a report. :slight_smile: