"Snap to floor" not working.Version 4.6 Preview

Hi ,

I am not sure if I should report any bugs I encounter in a preview version , but I have found that “snap to floor” in Unreal Engine 4.6 Preview does not seem to work.

I did a restart of engine , created a new project , made sure default “end” shortcut key is assigned , all
with same results.

Best Regards ,

Hi Ockertvs,

Since 4.4, we’ve been using an option in Transform Toolbar to enable or disable actor snapping:


This seems to be working fine for me in 4.6. When you say it’s not working, are you referring to another setting? What exactly happens when you try to place an actor in level with snapping on?

Hi ,
Yes I am aware of option described above.I really don’t know why it wasn’t working for me in 4.6 Preview at first , though after your reply I went to look again without changing any settings and it worked first time.I feel quite embarrassed , as I don’t know what caused it not to work earlier.Thank you for kind reply , and I apologize for inconvenience.
Best regards

It’s absolutely not an inconvenience and there’s no reason to be embarrassed. Sometimes things unexpectedly don’t work, and we want to try to minimize problems for you guys! If this happens again for you, please feel free to reopen this post with any details you may have. Thanks!

Hi ,
I’ve been able to reproduce problem I’ve been experiencing , after further testing.
Seems to be a problem with BSP only.

In Unreal Engine 4.5.1 , with a BSP selected within level , shortcut key “end” would’ve snapped BSP to “floor” below regardless of “surface snapping option” in toolbar.

I created a new project in 4.5.1 , dragged a BSP Cube to my scene , positioned it above floor , used “end” key and BSP was able to snap to surface below.

Tried same steps in 4.6 Preview and BSP does not snap to surface below.When I hit “end” I do see some changes in Outliner and Details Panel of selected BSP.If “End” is hit with BSP selected through outliner , selected actor in outliner changes.When BSP is selected by clicking on BSP surface through Level Editor ,and “End” is hit , it seems to collapse “Surface Materials” section in details panel of selected BSP.

Hope this helps , and hopefully could be reproduced on your end.
Thanks again
Best regards!

Ah, I see what you’re saying now, it only seems to affect BSPs. I can verify that this is not working correctly in 4.6. I also checked our internal build and it seems to be working fine there, so this should be working again in 4.7 for BSPs. Thanks for your report!

Pleasure , and thank you.

I had same problem, BSP would snap to floor but it wouldn’t drop to floor. I noticed some other problems with it doing something random with certain actions, but will wait until 4.7 as post was already closed and I haven’t tested 4.7 yet, don’t wanna be making any duplicate posts.